Modify

Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#9082 closed defect (fixed)

opkg install segfaults

Reported by: Dmitry Kurochkin <dmitry.kurochkin@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

I get segmentation fault when run

opkg install kmod-leds-wndr3700-usb

I have just upgraded the system to the latest trunk, including kernel. Did not see such problem before the upgrade. Previous version was about 10 days old trunk. Attached is opkg debug log.

If I run the same command again, it does not segfault but freezes at the same point after:

opkg_install_pkg: Installing maintainer scripts.

Attachments (1)

opkg.log (239.5 KB) - added by Dmitry Kurochkin <dmitry.kurochkin@…> 7 years ago.
"opkg install -V4 kmod-leds-wndr3700-usb" segmentation fault

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by Dmitry Kurochkin <dmitry.kurochkin@…>

"opkg install -V4 kmod-leds-wndr3700-usb" segmentation fault

comment:1 Changed 7 years ago by Dmitry Kurochkin <dmitry.kurochkin@…>

Turns out that opkg freezes trying to read package lists or some other info (from /var/usr/lib/opkg/info/ IIRC). I did not investigate the segfault, but the root cause is probably the same. Running ls on the directory freezes as well. I was using external root with ext4, so I think the problem is in the mini_fo. Probably this is the same issue as #8542, which has been fixed recently.

Please close the bug.

comment:2 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.