Modify

Opened 7 years ago

Last modified 4 years ago

#9077 new defect

dnsmasq: IPv6 TCP query in response to a UDP truncated response fails.

Reported by: scott.openwrt@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Backfire 10.03.1 RC4
Keywords: Cc:

Description

I am using OpenWrt Backfire 10.03.1-rc4 on a TP-link WR1043ND.

I have an IPv6 address from my ISP and can talk native IPv6 to their servers and the internet.

I have setup dnsmasq to resolve my internal names and forward other names to my ISPs IPv6 DNS servers. However, I find that cloud.github.com doesn't work, github.com does. Using tcpdump I found that the UDP response for cloud.github.com was truncated (the DNS truncated bit was set), the query was then tried over TCP, but this fails. Wireshark trace is attached.

Attachments (1)

cloud_fail.log (40.1 KB) - added by scott.openwrt@… 7 years ago.
wireshark trace for failure.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by scott.openwrt@…

wireshark trace for failure.

comment:1 Changed 6 years ago by carlopires

I have the same error for IPv4 and www.orkut.com domain.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.