Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#9039 closed defect (fixed)

use uClibc++ for Yate package

Reported by: Dmitry Kurochkin <dmitry.kurochkin@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Currently, Yate is broken because the binary is linked with libstdc++ but the package does not depend on libstdcpp. Attached patch makes Yate package to use uClibc++ library.

Note: I have no experience with OpenWrt development and used Kismet package Makefile as an example. So the fix may not be correct. But at least the package builds for WNDR3700 target and "yate --help" runs fine.

Attachments (2)

yate-uClibc++.patch (2.4 KB) - added by Dmitry Kurochkin <dmitry.kurochkin@…> 7 years ago.
Use uClibc++ for Yate package.
yate-uClibc++_2.patch (2.4 KB) - added by Dmitry Kurochkin <dmitry.kurochkin@…> 7 years ago.
Use uClibc++ for Yate package, version 2.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by Dmitry Kurochkin <dmitry.kurochkin@…>

Use uClibc++ for Yate package.

Changed 7 years ago by Dmitry Kurochkin <dmitry.kurochkin@…>

Use uClibc++ for Yate package, version 2.

comment:1 Changed 7 years ago by Dmitry Kurochkin <dmitry.kurochkin@…>

Apparently, Yate ignores CXXFLAGS and uses CFLAGS instead. Patch version 2 changed accordingly.

comment:2 Changed 7 years ago by cshore

  • Resolution set to fixed
  • Status changed from new to closed

Fixed r26173. Thanks for the report and patch.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.