Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#9024 closed defect (invalid)

Latest ath9k patch in trunk broken

Reported by: anonymous Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

Applying ./patches/572-ath9k_fix_tx_flush.patch using plaintext: 
patching file drivers/net/wireless/ath/ath9k/main.c
Hunk #1 FAILED at 2149.
1 out of 1 hunk FAILED -- saving rejects to file drivers/net/wireless/ath/ath9k/main.c.rej
Patch failed!  Please fix ./patches/572-ath9k_fix_tx_flush.patch!
make[3]: *** [/home/trondah/kamikaze/build_dir/linux-ar71xx_generic/compat-wireless-2011-02-25/.prepared_256e31046eab0021cca939d3f85636b5] Error 1
make[3]: Leaving directory `/home/trondah/kamikaze/package/mac80211'
make[2]: *** [package/mac80211/compile] Error 2
make[2]: Leaving directory `/home/trondah/kamikaze'
make[1]: *** [/home/trondah/kamikaze/staging_dir/target-mips_r2_uClibc-0.9.32/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/trondah/kamikaze'
make: *** [world] Error 2

Attachments (1)

572-ath9k_fix_tx_flush.patch (1.8 KB) - added by arokh <trondah@…> 7 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by jow

I cannot reproduce it. Is you mac80211 tree unclean maybe?
What's the result of the following command?

make package/mac80211/{clean,compile} V=99

comment:2 Changed 7 years ago by arokh <trondah@…>

Yep completely clean, same result.

I went over the reject file and created a new patch for the offending one, works now.

Changed 7 years ago by arokh <trondah@…>

comment:3 Changed 7 years ago by acoul

try to sync to a fresh trunk and issue a "make distclean" before compile.

comment:4 Changed 7 years ago by arokh <trondah@…>

Like I said, the tree is completely clean. I wipe out build_dir, staging_dir and tmp after each build, similar to a distclean.

I just extracted compat-wireless-2011-02-25 and applied the patches manually, same result:

trondah@ff0:~/compat-wireless-2011-02-25$ for a in path/to/patches/*; do patch -p1 < $a; done
patching file config.mk
patching file config.mk
patching file include/linux/rfkill.h
patching file config.mk
patching file Makefile
patching file config.mk
patching file config.mk
patching file config.mk
patching file config.mk
patching file config.mk
patching file config.mk
patching file config.mk
patching file config.mk
patching file config.mk
patching file drivers/net/wireless/b43/main.c
patching file drivers/net/wireless/b43legacy/main.c
patching file config.mk
patching file include/linux/compat-2.6.36.h
patching file compat/Makefile
patching file config.mk
patching file compat/compat-2.6.39.c
patching file drivers/net/wireless/zd1211rw/zd_chip.h
patching file compat/compat-2.6.28.c
patching file compat/compat-2.6.33.c
patching file include/linux/compat-2.6.28.h
patching file include/linux/compat-2.6.33.h
patching file compat/compat-2.6.28.c
patching file compat/compat-2.6.29.c
patching file include/linux/compat-2.6.28.h
patching file config.mk
patching file drivers/net/wireless/iwlwifi/iwl-agn.c
patching file drivers/net/wireless/iwlegacy/iwl3945-base.c
patching file drivers/net/wireless/libertas_tf/cmd.c
patching file drivers/net/wireless/libertas_tf/if_usb.c
patching file drivers/net/wireless/libertas_tf/main.c
patching file net/wireless/core.c
patching file net/wireless/lib80211.c
patching file net/wireless/lib80211_crypt_tkip.c
patching file net/wireless/reg.c
patching file drivers/net/wireless/iwlegacy/iwl4965-base.c
patching file drivers/net/wireless/ath/ath5k/initvals.c
patching file drivers/net/wireless/ath/ath5k/dma.c
patching file drivers/net/wireless/ath/ath9k/debug.c
patching file drivers/net/wireless/ath/ath9k/hw.h
patching file drivers/net/wireless/ath/ath9k/hw.c
patching file drivers/net/wireless/ath/ath9k/gpio.c
patching file drivers/net/wireless/ath/ath9k/init.c
patching file drivers/net/wireless/ath/ath9k/hw.c
patching file drivers/net/wireless/ath/regd.c
patching file drivers/net/wireless/ath/regd.c
patching file include/linux/ath9k_platform.h
patching file drivers/net/wireless/ath/ath9k/init.c
patching file drivers/net/wireless/ath/ath9k/init.c
patching file drivers/net/wireless/ath/ath9k/hw.h
patching file drivers/net/wireless/ath/ath9k/gpio.c
patching file include/linux/ath9k_platform.h
patching file include/linux/ath5k_platform.h
patching file drivers/net/wireless/ath/ath5k/eeprom.c
patching file drivers/net/wireless/ath/ath5k/pci.c
patching file drivers/net/wireless/ath/ath9k/debug.c
patching file drivers/net/wireless/ath/ath9k/ath9k.h
patching file drivers/net/wireless/ath/ath9k/gpio.c
patching file drivers/net/wireless/ath/ath9k/main.c
Hunk #1 succeeded at 1214 (offset -2 lines).
patching file drivers/net/wireless/ath/ath9k/init.c
patching file drivers/net/wireless/ath/ath9k/hw.c
patching file include/net/mac80211.h
Hunk #1 succeeded at 2199 (offset -10 lines).
patching file net/mac80211/sta_info.c
patching file net/mac80211/sta_info.h
patching file drivers/net/wireless/ath/ath9k/ath9k.h
patching file drivers/net/wireless/ath/ath9k/main.c
Hunk #1 succeeded at 1789 (offset -2 lines).
Hunk #2 succeeded at 2210 (offset -2 lines).
patching file drivers/net/wireless/ath/ath9k/xmit.c
patching file drivers/net/wireless/ath/ath9k/hw-ops.h
patching file drivers/net/wireless/ath/ath9k/hw.h
patching file drivers/net/wireless/ath/ath9k/ar9002_mac.c
patching file drivers/net/wireless/ath/ath9k/ar9003_mac.c
patching file drivers/net/wireless/ath/ath9k/mac.h
patching file drivers/net/wireless/ath/ath9k/xmit.c
patching file include/net/cfg80211.h
patching file include/linux/nl80211.h
patching file net/wireless/nl80211.c
patching file net/mac80211/sta_info.h
patching file net/mac80211/rx.c
patching file net/mac80211/cfg.c
patching file drivers/net/wireless/ath/ath9k/recv.c
patching file net/mac80211/rc80211_minstrel_ht.c
patching file drivers/net/wireless/ath/ath9k/hw.h
patching file drivers/net/wireless/ath/ath9k/xmit.c
patching file drivers/net/wireless/ath/ath9k/mac.c
patching file drivers/net/wireless/ath/ath9k/mac.h
patching file drivers/net/wireless/ath/ath9k/main.c
Hunk #1 FAILED at 2149.
1 out of 1 hunk FAILED -- saving rejects to file drivers/net/wireless/ath/ath9k/main.c.rej
patching file drivers/net/wireless/ath/ath9k/ath9k.h
patching file drivers/net/wireless/ath/ath9k/xmit.c
patching file drivers/net/wireless/ath/ath9k/mac.c
patching file drivers/net/wireless/ath/ath9k/mac.h
patching file drivers/net/wireless/ath/ath9k/beacon.c
patching file net/mac80211/rx.c
patching file drivers/net/wireless/rt2x00/rt2x00pci.c
patching file drivers/net/wireless/rt2x00/rt2x00pci.c
patching file drivers/net/wireless/mwl8k.c
Hunk #1 succeeded at 4507 (offset 5 lines).
patching file drivers/net/wireless/p54/eeprom.c
patching file net/mac80211/main.c
patching file net/mac80211/scan.c
patching file drivers/net/wireless/b43/b43.h
patching file drivers/net/wireless/b43/main.c
Hunk #3 succeeded at 5107 (offset 2 lines).
patching file drivers/net/wireless/b43/Makefile
patching file drivers/net/wireless/b43/main.c
patching file drivers/net/wireless/b43/pio.h
patching file scripts/admin-clean.sh
patching file scripts/admin-refresh.sh
patching file scripts/admin-update.sh
patching file scripts/check_config.sh
patching file scripts/driver-select
patching file scripts/gen-compat-autoconf.sh
patching file scripts/gen-stable-release.sh
patching file scripts/skip-colors

comment:5 Changed 7 years ago by jow

As I said, I cannot reproduce that here:

jow@wws-7 /tmp $ wget http://mirror2.openwrt.org/sources/compat-wireless-2011-02-25.tar.bz2
--2011-03-11 16:09:15--  http://mirror2.openwrt.org/sources/compat-wireless-2011-02-25.tar.bz2
Resolving mirror2.openwrt.org... 46.4.11.11
Connecting to mirror2.openwrt.org|46.4.11.11|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 4445542 (4,2M) [application/x-bzip2]
Saving to: `compat-wireless-2011-02-25.tar.bz2'

100%[=======================================================================================================================================================================>] 4.445.542   1,64M/s   in 2,6s    

2011-03-11 16:09:18 (1,64 MB/s) - `compat-wireless-2011-02-25.tar.bz2' saved [4445542/4445542]

jow@wws-7 /tmp $ tar -xjf compat-wireless-2011-02-25.tar.bz2 
jow@wws-7 /tmp $ cd compat-wireless-2011-02-25
jow@wws-7 /tmp/compat-wireless-2011-02-25 $ for p in ~/devel/openwrt/trunk/package/mac80211/patches/*.patch; do patch -p1 < $p; done
patching file config.mk
patching file config.mk
patching file include/linux/rfkill.h
patching file config.mk
patching file Makefile
patching file config.mk
patching file config.mk
patching file config.mk
patching file config.mk
patching file config.mk
patching file config.mk
patching file config.mk
patching file config.mk
patching file config.mk
patching file drivers/net/wireless/b43/main.c
patching file drivers/net/wireless/b43legacy/main.c
patching file config.mk
patching file include/linux/compat-2.6.36.h
patching file compat/Makefile
patching file config.mk
patching file compat/compat-2.6.39.c
patching file drivers/net/wireless/zd1211rw/zd_chip.h
patching file compat/compat-2.6.28.c
patching file compat/compat-2.6.33.c
patching file include/linux/compat-2.6.28.h
patching file include/linux/compat-2.6.33.h
patching file compat/compat-2.6.28.c
patching file compat/compat-2.6.29.c
patching file include/linux/compat-2.6.28.h
patching file config.mk
patching file drivers/net/wireless/iwlwifi/iwl-agn.c
patching file drivers/net/wireless/iwlegacy/iwl3945-base.c
patching file drivers/net/wireless/libertas_tf/cmd.c
patching file drivers/net/wireless/libertas_tf/if_usb.c
patching file drivers/net/wireless/libertas_tf/main.c
patching file net/wireless/core.c
patching file net/wireless/lib80211.c
patching file net/wireless/lib80211_crypt_tkip.c
patching file net/wireless/reg.c
patching file drivers/net/wireless/iwlegacy/iwl4965-base.c
patching file drivers/net/wireless/ath/ath5k/initvals.c
patching file drivers/net/wireless/ath/ath5k/dma.c
patching file drivers/net/wireless/ath/ath9k/debug.c
patching file drivers/net/wireless/ath/ath9k/hw.h
patching file drivers/net/wireless/ath/ath9k/hw.c
patching file drivers/net/wireless/ath/ath9k/gpio.c
patching file drivers/net/wireless/ath/ath9k/init.c
patching file drivers/net/wireless/ath/ath9k/hw.c
patching file drivers/net/wireless/ath/regd.c
patching file drivers/net/wireless/ath/regd.c
patching file include/linux/ath9k_platform.h
patching file drivers/net/wireless/ath/ath9k/init.c
patching file drivers/net/wireless/ath/ath9k/init.c
patching file drivers/net/wireless/ath/ath9k/hw.h
patching file drivers/net/wireless/ath/ath9k/gpio.c
patching file include/linux/ath9k_platform.h
patching file include/linux/ath5k_platform.h
patching file drivers/net/wireless/ath/ath5k/eeprom.c
patching file drivers/net/wireless/ath/ath5k/pci.c
patching file drivers/net/wireless/ath/ath9k/debug.c
patching file drivers/net/wireless/ath/ath9k/ath9k.h
patching file drivers/net/wireless/ath/ath9k/gpio.c
patching file drivers/net/wireless/ath/ath9k/main.c
patching file drivers/net/wireless/ath/ath9k/init.c
patching file drivers/net/wireless/ath/ath9k/hw.c
patching file include/net/mac80211.h
patching file net/mac80211/sta_info.c
patching file net/mac80211/sta_info.h
patching file drivers/net/wireless/ath/ath9k/ath9k.h
patching file drivers/net/wireless/ath/ath9k/main.c
patching file drivers/net/wireless/ath/ath9k/xmit.c
patching file drivers/net/wireless/ath/ath9k/hw-ops.h
patching file drivers/net/wireless/ath/ath9k/hw.h
patching file drivers/net/wireless/ath/ath9k/ar9002_mac.c
patching file drivers/net/wireless/ath/ath9k/ar9003_mac.c
patching file drivers/net/wireless/ath/ath9k/mac.h
patching file drivers/net/wireless/ath/ath9k/xmit.c
patching file include/net/cfg80211.h
patching file include/linux/nl80211.h
patching file net/wireless/nl80211.c
patching file net/mac80211/sta_info.h
patching file net/mac80211/rx.c
patching file net/mac80211/cfg.c
patching file drivers/net/wireless/ath/ath9k/recv.c
patching file net/mac80211/rc80211_minstrel_ht.c
patching file drivers/net/wireless/ath/ath9k/hw.h
patching file drivers/net/wireless/ath/ath9k/xmit.c
patching file drivers/net/wireless/ath/ath9k/mac.c
patching file drivers/net/wireless/ath/ath9k/mac.h
patching file drivers/net/wireless/ath/ath9k/main.c
patching file drivers/net/wireless/ath/ath9k/ath9k.h
patching file drivers/net/wireless/ath/ath9k/xmit.c
patching file drivers/net/wireless/ath/ath9k/mac.c
patching file drivers/net/wireless/ath/ath9k/mac.h
patching file drivers/net/wireless/ath/ath9k/beacon.c
patching file net/mac80211/rx.c
patching file drivers/net/wireless/rt2x00/rt2x00pci.c
patching file drivers/net/wireless/rt2x00/rt2x00pci.c
patching file drivers/net/wireless/mwl8k.c
patching file drivers/net/wireless/p54/eeprom.c
patching file net/mac80211/main.c
patching file net/mac80211/scan.c
patching file drivers/net/wireless/b43/b43.h
patching file drivers/net/wireless/b43/main.c
patching file drivers/net/wireless/b43/Makefile
patching file drivers/net/wireless/b43/main.c
patching file drivers/net/wireless/b43/pio.h
patching file scripts/admin-clean.sh
patching file scripts/admin-refresh.sh
patching file scripts/admin-update.sh
patching file scripts/check_config.sh
patching file scripts/driver-select
patching file scripts/gen-compat-autoconf.sh
patching file scripts/gen-stable-release.sh
patching file scripts/skip-colors
jow@wws-7 /tmp/compat-wireless-2011-02-25 $ svn diff ~/devel/openwrt/trunk/package/mac80211/patches/*.patch
jow@wws-7 /tmp/compat-wireless-2011-02-25 $

comment:6 Changed 7 years ago by jow

Do you maybe have unversioned, custom patches in your package/mac80211/ ?

comment:7 Changed 7 years ago by arokh <trondah@…>

Ok, found the problem, although I'm not sure what's happened here. I redownloaded compat-wireless-2011-02-25 and checked the md5sum, it's different from the one I had locally. I don't get how the buildsystem skipped the md5sum check though, I'll look into that later, gotta run. Sorry for wasting your time :)

comment:8 Changed 7 years ago by acoul

  • Resolution set to invalid
  • Status changed from new to closed

good you solved your problem. I am closing this ticket.

comment:9 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.