Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8976 closed defect (fixed)

AR7: Cannot compile kernel on trunk (25868)

Reported by: Unaimed Owned by: florian
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc: un_aimed@…

Description

The kernel cannot compile on trunk. I've only tried with AR7 as that is what I use. Same problem on 2.6.37.1 and .2.

{{{net/sched/act_connmark.c: In function 'tcf_connmark':
net/sched/act_connmark.c:73:15: error: 'struct nf_conn' has no member named 'mark'}}}

I've done make clean and dirclean but this does not help. The same openwrt config worked when compiling last time for 2.6.32.

Attachments (1)

.config (53.4 KB) - added by Unaimed 7 years ago.
openwrt config

Download all attachments as: .zip

Change History (15)

Changed 7 years ago by Unaimed

openwrt config

comment:1 Changed 7 years ago by anonymous

Apparently the wiki formatting didn't work. Trying again.

net/sched/act_connmark.c: In function 'tcf_connmark': net/sched/act_connmark.c:73:15: error: 'struct nf_conn' has no member named 'mark'

comment:2 Changed 7 years ago by anonymous2

same here with Atheros AR231x/AR5312

comment:3 Changed 7 years ago by anonymous

Problem caused by r25639. It relies on nf_conn having mark while mark is ifdeffed to CONFIG_NF_CONNTRACK_MARK.

Hack workaround is to comment the line which references mark in the patch.

comment:4 Changed 7 years ago by florian

I cannot reproduce the error on AR7 with 2.6.37.1.

comment:5 Changed 7 years ago by Unaimed

Did you try with my openwrt .config?

comment:6 Changed 7 years ago by florian

I used your config, but it does not even compile /net/sched/act_connmark.c. Restarting with a fresh config and selecting kmod-sched makes it compile it, and does not trigger the error.

comment:7 Changed 7 years ago by Unaimed

I've done some testing and found that it can be reproduced like this:

rm .config
make menuconfig

Target System: TI AR7
Base System -->

firewall: No

Kernel Modules -->

Network Support -->

kmod-sched: Yes

make clean && make

It's probably not specific to AR7.

comment:8 Changed 7 years ago by lores

same here with brcm47xx, latest trunk.

comment:9 follow-up: Changed 7 years ago by mstombs

Can confirm this still a bug with default AR7 config.

make menuconfig

and selecting more deselected contrack extra options allows compile to progress

comment:10 in reply to: ↑ 9 Changed 7 years ago by doddel

can confirm that bug it still present in Trunk June 14 2011. Indeed selecting 'conntrack extra' besides just 'conntrack' makes compile go through.

comment:11 Changed 7 years ago by pardinilist@…

Confirmed doddel's comment in June 23 2011. Using trunk 27265.
"selecting 'conntrack extra' besides just 'conntrack' makes compile go through".

comment:12 Changed 7 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to accepted

comment:13 Changed 7 years ago by florian

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed with r27457

comment:14 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.