Modify

Opened 7 years ago

Closed 7 years ago

#8968 closed defect (duplicate)

Compile OpenWRT on x86 platform

Reported by: fpaliuc@… Owned by: jow
Priority: normal Milestone: Backfire 10.03.1
Component: packages Version: Trunk
Keywords: Cc:

Description (last modified by hauke)

Hello!

I'm trying to compile OpenWRT on x86 platform with asterisk-1.8.x packages selected (as modules).

When it arrives to compile the mysql package, it gives this error:

libtool: link: gcc -rdynamic -o conf_to_src conf_to_src.o  -L/home/felix/trunk/staging_dir/target-i386_uClibc-0.9.32/usr/lib -L/home/felix/trunk/staging_dir/target-i386_uClibc-0.9.32/lib -L/home/felix/trunk/staging_dir/toolchain-i386_gcc-linaro_uClibc-0.9.32/usr/lib -L/home/felix/trunk/staging_dir/toolchain-i386_gcc-linaro_uClibc-0.9.32/lib
/usr/lib/gcc/i686-linux-gnu/4.4.5/../../../../lib/crt1.o: In function `_start':
(.text+0xc): undefined reference to `__libc_csu_fini'
/usr/lib/gcc/i686-linux-gnu/4.4.5/../../../../lib/crt1.o: In function `_start':
(.text+0x11): undefined reference to `__libc_csu_init'
/usr/lib/gcc/i686-linux-gnu/4.4.5/../../../../lib/crt1.o: In function `_start':
(.text+0x1d): undefined reference to `__libc_start_main'
conf_to_src.o: In function `print_array':
conf_to_src.c:(.text+0x18d): undefined reference to `__ctype_b_loc'
conf_to_src.c:(.text+0x226): undefined reference to `__ctype_b_loc'
conf_to_src.c:(.text+0x349): undefined reference to `__stack_chk_fail'
collect2: ld returned 1 exit status
make[4]: *** [conf_to_src] Error 1
make[4]: Leaving directory `/home/felix/trunk/build_dir/target-i386_uClibc-0.9.32/mysql-5.1.53/libmysql'
make[3]: *** [/home/felix/trunk/build_dir/target-i386_uClibc-0.9.32/mysql-5.1.53/.built] Error 2
make[3]: Leaving directory `/home/felix/trunk/feeds/packages/libs/mysql'
make[2]: *** [package/feeds/packages/mysql/compile] Error 2
make[2]: Leaving directory `/home/felix/trunk'
make[1]: *** [/home/felix/trunk/staging_dir/target-i386_uClibc-0.9.32/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/felix/trunk'
make: *** [world] Error 2

Attachments (0)

Change History (5)

comment:1 Changed 7 years ago by jow

  • Owner changed from developers to jow
  • Status changed from new to accepted

comment:2 Changed 7 years ago by fpaliuc@…

I've removed the downloaded trunk and downloaded all again and retried ... same error.

comment:3 Changed 7 years ago by d3xt3r

I'm trying to comple without asterisk packages selected and I'm getting the same error.

comment:4 Changed 7 years ago by hauke

  • Description modified (diff)

comment:5 Changed 7 years ago by hauke

  • Resolution set to duplicate
  • Status changed from accepted to closed

duplicate of #8342

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.