Modify

Opened 7 years ago

Closed 5 years ago

Last modified 4 years ago

#8966 closed defect (obsolete)

Kernel panic after start BLIP's ip-driver

Reported by: cmjr@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description (last modified by florian)

My name is Carlos Rodrigues and I’m starting work in WSN. After did a little scenario using 6lowpan using ubuntu, i'm
trying port that to openwrt. I'm using Mikrotik RB433UAH, MIB520 (USB) and IRIS motes.

If I start ip-driver only with BaseStation don't have problems. When I turn on at least one IRIS mote, the rb433 reboots.

In normal case, starts the proxy (to the mote):
2011-03-03T11:34:40.812WET: INFO: Starting to proxy for 0x1

I'm using openwrt r25799 (trunk).


root@OpenWrt:~/root# ./ip-driver -c serial_tun.conf /dev/ttyUSB1 iris
1970-01-01T00:01:13.tun0: Disabled Privacy Extensions
342UTC: INFO: Read config from 'serial_tun.conf'
1970-01-01T00:01:13.342UTC: INFO: Proxying neighbor advertisements to br-lan
1970-01-01T00:01:13.342UTC: INFO: Using channel 15
1970-01-01T00:01:13.342UTC: INFO: Retries: 5
1970-01-01T00:01:13.343UTC: INFO: telnet console server running on port 6106
1970-01-01T00:01:13.348UTC: INFO: created tun device: tun0
1970-01-01T00:01:14.750UTC: INFO: interface device successfully initialized
1970-01-01T00:01:14.750UTC: INFO: starting radvd on device tun0

blip:OpenWrt> Kernel unaligned instruction access[#1]:
Cpu 0
$ 0   : 00000000 7f80dd54 87a0ddf8 03ff0000
$ 4   : 801d8c48 00000000 00000000 802c0000
$ 8   : 00000000 00000002 85007d36 00000000
$12   : 00000000 00000030 87a0dec4 00000001
$16   : 87a0dcd8 80304228 00000000 870fac00
$20   : 00000001 80304248 802c6ac8 80290d14
$24   : 00000000 800d7d98
$28   : 87a0c000 87a0dc78 802c0000 801dea68
Hi    : 0000001d
Lo    : 00001374
epc   : 801d8c33 0x801d8c33
    Tainted: P
ra    : 801dea68 0x801dea68
Status: 1000fc03    KERNEL EXL IE
Cause : 00800010
BadVA : 801d8c33
PrId  : 00019374 (MIPS 24Kc)
Modules linked in: usbhid ftdi_sio hid usb_storage usbserial evdev ohci_hcd ath_pci ath_hal(P) nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack ehci_hcd sd_mod pppoe pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables sit tunnel6 tunnel4 tun ppp_async ppp_generic slhc usbcore scsi_mod nls_base crc_ccitt ipv6 leds_gpio button_hotplug gpio_buttons input_polldev input_core
Process ip-driver (pid: 976, threadinfo=87a0c000, task=879ec880, tls=2af732f0)
Stack : 00000002 870f2ce8 870f6380 87174400 870fac00 801de7d4 a7146000 00000000
        00000000 00000000 87aa6900 00000000 ffffffff 801e7030 87b3f400 870f6380
        00000000 870f6380 80304248 87ba58c8 87b3f4d4 87b9b080 0000000e 800a8854
        00000000 802c6b00 802c6ac0 00000000 802c6ad4 802c6af4 00100100 801e70f0
        87aa6900 00000000 00000000 00000001 00000001 800aa5cc 87a0ddd0 802c6b00
        ...
Call Trace:[<870f2ce8>] 0x870f2ce8
[<801de7d4>] 0x801de7d4
[<801e7030>] 0x801e7030
[<87ba58c8>] 0x87ba58c8
[<800a8854>] 0x800a8854
[<801e70f0>] 0x801e70f0
[<800aa5cc>] 0x800aa5cc
[<801e74e0>] 0x801e74e0
[<80081f3c>] 0x80081f3c
[<80082030>] 0x80082030
[<801e8ad8>] 0x801e8ad8
[<87b79570>] 0x87b79570
[<80077f08>] 0x80077f08
[<8008e5d8>] 0x8008e5d8
[<8008eb64>] 0x8008eb64
[<87b79a54>] 0x87b79a54
[<800d7e40>] 0x800d7e40
[<8018f3bc>] 0x8018f3bc
[<80077f08>] 0x80077f08
[<80189fd4>] 0x80189fd4
[<800d8630>] 0x800d8630
[<800d8888>] 0x800d8888
[<80062544>] 0x80062544
[<8008134c>] 0x8008134c


Code: 0c07  5954  0260 <3021> afa2  0010  27a2  0034  1242
Kernel panic - not syncing: Fatal exception in interrupt
Rebooting in 3 seconds..

Attachments (0)

Change History (6)

comment:1 Changed 7 years ago by jow

Please recompile your kernel with symbol table information to get meaningful stack traces. You'll find this option in make menuconfig, global build settings.

comment:2 Changed 7 years ago by anonymous

root@OpenWrt:~# ./ip-driver -c serial_tun.conf /dev/ttyUSB1 iris
2011-03-05T18:42:52.tun0: Disabled Privacy Extensions
005UTC: INFO: Read config from 'serial_tun.conf'
2011-03-05T18:42:52.005UTC: INFO: Proxying neighbor advertisements to br-lan
2011-03-05T18:42:52.005UTC: INFO: Using channel 15
2011-03-05T18:42:52.005UTC: INFO: Retries: 5
2011-03-05T18:42:52.006UTC: INFO: telnet console server running on port 6106
2011-03-05T18:42:52.011UTC: INFO: created tun device: tun0
2011-03-05T18:42:53.420UTC: INFO: interface device successfully initialized
2011-03-05T18:42:53.420UTC: INFO: starting radvd on device tun0
CPU 0 Unable to handle kernel paging request at virtual address 0003ff06, epc == 801d86e5, ra == 801e0d0c
Oops#1:
Cpu 0
$ 0 : 00000000 7ffe7e14 00000000 03ff0000
$ 4 : 0003ff00 00000001 00000000 802f0000
$ 8 : 00000000 00000002 85007d36 00000000
$12 : 00000000 00000030 87a01ec4 00000001
$16 : 87a01da8 8032e228 00000000 87009800
$20 : 00000001 8032e248 802f0ac8 802b97bc
$24 : 00000000 800d9ed4
$28 : 87a00000 87a01c78 802f0000 801e0d0c
Hi : 00000000
Lo : 00000000
epc : 801d86e5 ar724x_pci_irq_mask+0x2d/0x3c

Not tainted

ra : 801e0d0c skb_release_head_state+0x6c/0xc8
Status: 1000f403 KERNEL EXL IE
Cause : 00800008
BadVA : 0003ff06
PrId : 00019374 (MIPS 24Kc)
Modules linked in: ftdi_sio usbserial ohci_hcd nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack pppoe pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables tunnel6 tunnel4 tun ppp_async ppp_generic slhc usbcore nls_base crc_ccitt ipv6 leds_gpio button_hotplug gpio_buttons input_polldev input_core
Process ip-driver (pid: 1072, threadinfo=87a00000, task=879c9980, tls=2b1be2f0)
Stack : 00000000 87008cd4 87008c00 87041320 87009800 801e0a78 87a01c8c 800871b4

00000000 a700a040 87a5d9c0 87062780 879b8800 801e92d4 0000000e 800aa888
00000000 3b9aca00 8032e248 87008cd4 87008c00 bc000000 00000002 87042ce8
87819130 802f0b00 802f0ac0 00000000 802f0ad4 802f0af4 00100100 801e9394
87a5d9c0 00000000 ffffffff 87b85398 00000001 80328290 8032828c 802f0b00
...

Call Trace:
[<801d86e5>] ar724x_pci_irq_mask+0x2d/0x3c
[<801e0d0c>] skb_release_head_state+0x6c/0xc8
[<801e0a78>] kfree_skb+0x10/0xc4
[<801e92d4>]
netif_receive_skb+0x390/0x3b8
[<801e9394>] process_backlog+0x98/0x168
[<801e9784>] net_rx_action+0xa0/0x1d4
[<800822c8>] do_softirq+0xb4/0x160
[<800823bc>] do_softirq+0x48/0x68
[<801ead7c>] netif_rx_ni+0x28/0x38
[<87a59570>] tun_get_socket+0x464/0x1484 [tun]
[<8008e978>]
queue_work+0x208/0x23c

Code: 004c 3463 4000 <ac43> 004c 8c42 004c 03e0 0008
Disabling lock debugging due to kernel taint
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
Kernel panic - not syncing: Fatal exception in interrupt
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
Rebooting in 3 seconds..
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
drivers/usb/serial/generic.c: usb_serial_generic_read_bulk_callback - port 1
ftdi_sio ttyUSB1: usb_serial_generic_read_bulk_callback - length = 2, data = 01 60
(...)

This line repeats and then reboots.

comment:3 Changed 7 years ago by cmjr@…

Any news?

comment:4 Changed 5 years ago by florian

  • Description modified (diff)

comment:5 Changed 5 years ago by nbd

  • Resolution set to obsolete
  • Status changed from new to closed

looks like an issue in an old kernel, reopen if it's still reproducible with current trunk

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.