Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8959 closed defect (fixed)

uhttpd dies with msg: can't resolve symbol '__fpcmp_parts_f'

Reported by: Stephan Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Hi,
I have checked out and compiled revision 25818. Even tried a
"make distclean" in advance to make sure all old stuff is gone.

Apparent problem is that I get no LuCI Weg-Interface, when I start
uhttpd and try to access it from the Web Browser, I can see it dying:

root@wlan:/etc/config# /usr/sbin/uhttpd -f -h /www -r wlan -x /cgi-bin

-p 80

socket(): Address family not supported by protocol
Notice: Unable to load Lua plugin - disabling Lua support! (Reason: File not found)
/usr/sbin/uhttpd: can't resolve symbol 'fpcmp_parts_f'
root@wlan:/etc/config#

...seems to be a problem in ulibc's most recent libm library?

regards,
Stephan

Attachments (0)

Change History (13)

comment:1 Changed 7 years ago by rene.kliment(that bloddy thing)gmail.com

Same here.

root@OpenWrt:~# /usr/sbin/uhttpd -f -h /www -r wlan -x /cgi-bin -p 80
/usr/sbin/uhttpd: can't resolve symbol '__fpcmp_parts_f'

Also

root@OpenWrt:~# htop
htop: can't resolve symbol '__pack_f'

Don't know, wherether it's the same thing or not.
Seems like new things aren't always that super cool as they seem to be :-(
Hope it will be fixed soon. I'm looking forward to watch TV over my network and stream sound using PulseAudio :-)

comment:2 Changed 7 years ago by Stephan

works fine in r25854 for me. Was maybe a problem in ulibc ? No idea...

Anyway, can be closed,

Thenks
Stephan

comment:3 Changed 7 years ago by René Kliment <rene (that thing) renekliment.cz>

I have also r25854, but it doesn't work for me :-(
I have Ubnt RouterStation Pro.

comment:4 Changed 7 years ago by René Kliment <rene (that thing) renekliment.cz>

Tested with r25862 (I know, there is nothing regarding that, just to be sure). Doesn't work either.

comment:5 Changed 7 years ago by Stephan

Here is what I did:
Saved my old .config file (approx 3 weeks old)

Completely removed all sources, made a brand new svn checkout for trunk.
(this also causes additional stuff beeing downloaded in the most recent version,

especially uglibc (i have some feeling that this is where the problem comes from)

make menuconfig, go to Advanced Config Options (for developpers),

toolchain options.

check Binutils Version (2.20.1)
GCC compiler Version (gcc 4.5.2 with Linaro enhancements)
uClibc Version (uClib 0.9.32-git)

I was poking around with these settings erlier, and I am not sure if it makes a
difference if your old .config has other (older) values.

Then i did a "load alternate config" to import my old config, went
to the above settings and set them so the noted values. These values
are the defaults which come with the recent version.

did a make clean, make and all went fine.

Don't really know if i got to the root cause of this problem using this
procedure, but that's how it worked for me

regards,
Stephan



comment:6 Changed 7 years ago by jow

This issue is toolchain related, it will not solve itself after a simple svn up and make, a full rebuild is needed.

comment:7 Changed 7 years ago by René Kliment <rene (that thing) renekliment.cz>

Ok, this is driving me crazy, compiling the whole whing over and over.
Deleted everything, got completely new svn checkout, I've checked that those toolchain apps versions match, did "make clean" and "make" and it seems the only thing I can do is to go f* myself.
Still doesn't work for me :-(
Any ideas?
PS: running on r25865

comment:8 Changed 7 years ago by Jim Henderson <hendersj@…>

In my builds, I was already set to Binutils 2.20.1 and uClibc 0.9.32-git, so I'm going to try it with the GCC version (I had left it at the default which was 4.33 with the CodeSourcery enhancements) and see if that helps me with this issue.

I had done a full rebuild on mine (I've scripted that, actually) and that wasn't sufficient, so I'm hoping the gcc change will address the issue for me.

comment:9 Changed 7 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r25912, requires a full rebuild to take effect

comment:10 Changed 7 years ago by Jim Henderson <hendersj@…>

Just tried this with r25914, and it's still dying here. Did a 'make distclean' and then did a svn update, followed by copying my old config file over and doing a 'make menuconfig' (which seems to update things that need it). Is it confirmed that we need to use the gcc version that's indicated above (I think that I reverted to 4.33 with this method)?

comment:11 Changed 7 years ago by nbd

You need to use the default gcc version (4.5.2 + linaro)

comment:12 Changed 7 years ago by Jim Henderson <hendersj@…>

Thanks, that did the trick. :-)

comment:13 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.