Modify

Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#8935 closed enhancement (wontfix)

Compile chan_datacard and asterisk-1-8.x for Broadcom BCM63XX platform

Reported by: Felix Owned by: zandbelt
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Hi,

coudl u add support for chan_datacard ?

Attachments (4)

chan-datacard.patch (2.6 KB) - added by zandbelt 7 years ago.
chan-datacard2.patch (3.4 KB) - added by zandbelt 7 years ago.
001-endianness-fix.patch (642 bytes) - added by fpaliuc@… 7 years ago.
Patch created by Paul Fertser <fercerpav@…>
Makefile (2.3 KB) - added by fpaliuc@… 7 years ago.
Makefile for chan_datacard and asterisk 1.8.3.2

Download all attachments as: .zip

Change History (18)

Changed 7 years ago by zandbelt

comment:1 Changed 7 years ago by zandbelt

  • Owner changed from developers to zandbelt
  • Status changed from new to assigned

a patch was added for current trunk/asterisk 1.8.x

comment:2 Changed 7 years ago by fpaliuc@…

I've cancelled the entire trunk from my PC. Downloaded it again and tried to recompile starting from zero. I get the same error:

In file included from helpers.c:18:
/home/felix/openwrt-backfire/staging_dir/target-mips_uClibc-0.9.30.1/usr/include/asterisk-1.8/include/asterisk/lock.h:137: error: expected specifier-qualifier-list before 'pthread_rwlock_t'
make[4]: * [helpers.o] Error 1
make[4]: Leaving directory `/home/felix/openwrt-backfire/build_dir/target-mips_uClibc-0.9.30.1/chan_datacard-1.0.r286'
make[3]:
* /home/felix/openwrt-backfire/build_dir/target-mips_uClibc-0.9.30.1/chan_datacard-1.0.r286/.built Error 2
make[3]: Leaving directory `/home/felix/openwrt-backfire/package/chan_datacard'
make[2]: * [package/chan_datacard/compile] Error 2
make[2]: Leaving directory `/home/felix/openwrt-backfire'
make[1]:
* /home/felix/openwrt-backfire/staging_dir/target-mips_uClibc-0.9.30.1/stamp/.package_compile Error 2
make[1]: Leaving directory `/home/felix/openwrt-backfire'
make: * [world] Error 2

comment:3 Changed 7 years ago by fpaliuc@…

I've tried several times to recompile (and 2 different PC's) but I didn't succeed. Could anybody try to compile chan_datacard on his/her PC?

comment:4 Changed 7 years ago by zandbelt

use trunk: svn co svn://svn.openwrt.org/openwrt/trunk, not the backfire branch

comment:5 Changed 7 years ago by fpaliuc@…

Thanks Hans, that did the trick. I was using the backfire branch before.

Changed 7 years ago by zandbelt

comment:6 Changed 7 years ago by zandbelt

added chan-datacard2.patch that also works on the backfire branch

comment:7 Changed 7 years ago by jow

  • Milestone changed from Backfire 10.03.1 to Attitude Adjustment (trunk)
  • Version changed from Backfire 10.03.1 RC4 to Trunk

Retarget this ticket to trunk

comment:8 Changed 7 years ago by fpaliuc@…

Hello Hans!

I've tried the patches you've posted and I was able to compile chan_datacard for my BCM63xx device. The problem is that I have audio problems.

I'd like to use another fork of chan_datacard (Makhutov) and test on my device. The only problem is that they don't have a makefile for OpenWRT.

Could u modify the makefile you've emailed me in order to make it work with this fork:
http://forge.asterisk.org/gf/project/chan_datacard/

Thanks

comment:9 Changed 7 years ago by fpaliuc@…

Hello!

The problem of loud noise instead of audio was solved on Broadcom BCM63xx platform. It needs a patch that was developed by Paul Fertser <fercerpav@…>
I'd post it here but I don't know how to attach it ...

Changed 7 years ago by fpaliuc@…

Patch created by Paul Fertser <fercerpav@…>

Changed 7 years ago by fpaliuc@…

Makefile for chan_datacard and asterisk 1.8.3.2

comment:10 Changed 7 years ago by Mino

Hi There,
I used fpaliuc to compile and I got it at the first go!! however,
when I mov the ipk file into the openwrt box with asterisk18, this is what i get when trying to load the module under asterisk (module load chan_datacard.so)

Module 'chan_datacard.so' was not compiled with the same compile-time options as this version of Asterisk.
Module 'chan_datacard.so' will not be initialized as it may cause instability.
Module 'chan_datacard.so' could not be loaded.

and I tried both with the asterisk18 version currently available on the openwrt repository (Asterisk 1.8.3.2) and the asterisk18 file that was downloaded from digium website and compiled together with the chan_datacard module.

Both give the same problem.
Many thanks for your help

comment:11 Changed 7 years ago by fpaliuc

When compiling chan_datacard I've also compiled the OpenWRT image I use.

comment:12 Changed 7 years ago by Mino

Hi fpaulic, thanks for your reply. So it'a matter of recmpiling the whole image as well as the chan_datacard? I will try that.

comment:13 Changed 6 years ago by zandbelt

  • Resolution set to wontfix
  • Status changed from assigned to closed

if someone comes up with a complete working patch against the trunk, please re-open this ticket

comment:14 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.