Modify

Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#8918 closed defect (no_response)

Ruby fails to build

Reported by: arokh <trondah@…> Owned by: developers
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

mips-openwrt-linux-uclibc-gcc -shared -o ../../../.ext/mips-linux/dl/callback.so callback.o callback-0.o callback-1.o callback-2.o callback-3.o callback-4.o callback-5.o callback-6.o callback-7.o callback-8.o -L. -L../../.. -L.  -rdynamic -Wl,-export-dynamic   -lruby  -lpthread -lrt -ldl -lcrypt -lm   -lc
make[2]: Leaving directory `/home/trondah/kamikaze/build_dir/target-mips_r2_uClibc-0.9.32/ruby-1.9.2-p0/ext/dl/callback'
compiling dl/win32
compiling etc
../.././ext/etc/extconf.rb:8: undefined method `escape' for Shellwords:Module (NoMethodError)
	from ./ext/extmk.rb:156:in `load'
	from ./ext/extmk.rb:156:in `extmake'
	from ./ext/extmk.rb:445
	from ./ext/extmk.rb:441:in `each'
	from ./ext/extmk.rb:441
make[1]: *** [mkmain.sh] Error 1
make[1]: Leaving directory `/home/trondah/kamikaze/build_dir/target-mips_r2_uClibc-0.9.32/ruby-1.9.2-p0'
make: *** [/home/trondah/kamikaze/build_dir/target-mips_r2_uClibc-0.9.32/ruby-1.9.2-p0/.built] Error 2
make: Leaving directory `/home/trondah/kamikaze/feeds/packages/lang/ruby'

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by hauke

I am unable to reproduce this compile error. Does this still exist for you?

comment:2 Changed 6 years ago by nico

  • Priority changed from normal to response-needed
  • Resolution set to no_response
  • Status changed from new to closed

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.