Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8869 closed defect (fixed)

ImageBuilder run ar71xx (WR1043ND) for 2.6.37 kernel

Reported by: ghaverla@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Over the last few days, I've been playing make with your build environment. I started playing with DebWRT encapsulating OpenWRT, and I was getting frustrated, so I just moved to straight OpenWRT. I gather OpenWRT involves 2500+ packages, well my ImageBuilder run included about 2100. I had 12 packages or modules crash make, which out of 2100 is pretty good. The play by play is in your forum. My commentary at the beginning is minimal, better towards the end.

https://forum.openwrt.org/viewtopic.php?id=28622

Or, if wiki syntax eats things, id=28622. My id on your wiki is fortran, which is the language I feel most comfortable with (namely F-77). I've been running Debian since probably 1997, I still don't do toystory. The svn was from trunk on Friday (2011/02/11). The feeds update was a couple of hours after the svn checkout.

Attachments (0)

Change History (4)

comment:1 follow-up: Changed 7 years ago by Nilfred <nilfred@…>

Yeah, right! These packages where modified very, very, very upstream.

You jump from http://kernelnewbies.org/Linux_2_6_32 to http://kernelnewbies.org/Linux_2_6_37

support for aes for example http://kernelnewbies.org/Linux_2_6_35#head-7e43b74b0b1ff4a9f01829f0696fad06560b04fc

So expect problems to related packages. Stick to 2.6.32 for now.

This is not a bug: Invalid.

comment:2 in reply to: ↑ 1 Changed 7 years ago by ghaverla@…

Replying to Nilfred <nilfred@…>:

Yeah, right! These packages where modified very, very, very upstream.

You jump from http://kernelnewbies.org/Linux_2_6_32 to http://kernelnewbies.org/Linux_2_6_37

[... ]

This is not a bug: Invalid.

I'm sorry if I worded things wrong. I thought my commentary would correct that.

I thought it might be interesting to people developing OpenWRT, to see how far, and what problems came long, in building ImageBuilder for a kernel much newer than what OpenWRT currently is designed for.

If I left this as some comment in the forum, people compiling kernels in the hopes of advancing OpenWRT might never have seen it.

I thought it was rather great that so few other problems showed up, compiling OpenWRT against a kernel much newer than people are working with.

I've been working with Linux since 1.2.13. And I've patched kernel source to support token ring because it was necessary. I have been working with computers since 1977 and programming (mostly numerical methods, but all kinds of other stuff) since 1980. And I read a LOT (probably because I have Autism). Don't assume I am YAI in submitting a "bug".

I am not looking to make enemies. I think OpenWRT is what I want on my router, and I am willing to work to help that. I am not an EE or CompE graduate who has spend all his/her time doing operating systems. I do know a lot about computers (probably 60 languages and 10 OS).

I thought I was helping. If there is something else I could do, which would help, please let me know.

From my knowledge of operating systems (which I needed to start studying in 1984, as my programs were stretching limits), I see no reason why I shouldn't be running 2.6.37 as a kernel even though most of OpenWRT is running 2.6.32.

comment:3 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

The ar71xx target has been updated to Kernel 2.6.37.1 in r25715, it will hit the snapshot mirrors soon.

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.