Modify

Opened 11 years ago

Closed 10 years ago

Last modified 9 years ago

#879 closed enhancement (fixed)

Please add nth and random match modules and iptables support to the iptables-mod-ipopt package.

Reported by: gormot Owned by: florian
Priority: lowest Milestone:
Component: kernel Version:
Keywords: iptables, nth Cc:

Description

Please add nth and random match modules and related iptables support to the iptables-mod-ipopt and iptables-extra packages.
Modules and iptables patches are included with the 2.6 kernel and available with old patch-o-matic patches for netfilter for the 2.4 kernel.

For example here:
ftp://ftp.netfilter.org/pub/patch-o-matic/patch-o-matic-20031219.tar.bz2

Attachments (3)

009-random_and_ROUTE.patch (20.7 KB) - added by anonymous 10 years ago.
package/iptables patch to add random match and ROUTE target support
009-random_and_ROUTE.2.patch (20.7 KB) - added by anonymous 10 years ago.
package/iptables patch to add random match and ROUTE target support
623-netfilter_ROUTE.patch (26.0 KB) - added by anonymous 10 years ago.
target/linux/generic-2.4 patch that adds ROUTE target support

Download all attachments as: .zip

Change History (11)

comment:1 Changed 11 years ago by mbm

  • Keywords iptables nth added
  • Priority changed from normal to lowest
  • Type changed from defect to enhancement

comment:2 Changed 11 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned

comment:3 Changed 11 years ago by florian

  • Resolution set to wontfix
  • Status changed from assigned to closed

Please attach a patch for 2.6.21.1 and re-open with it as an attachment, thanks.

comment:4 Changed 11 years ago by anonymous

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:5 Changed 11 years ago by anonymous

Please Fix

comment:6 Changed 10 years ago by fxd0h

random and nth are in xt_statistic for kernels 2.6.x

comment:7 Changed 10 years ago by florian

  • Resolution set to fixed
  • Status changed from reopened to closed

xt_statistic added in [8716]. 2.4 should not be patched anymore which such stuff.

Changed 10 years ago by anonymous

package/iptables patch to add random match and ROUTE target support

Changed 10 years ago by anonymous

package/iptables patch to add random match and ROUTE target support

Changed 10 years ago by anonymous

target/linux/generic-2.4 patch that adds ROUTE target support

comment:8 Changed 10 years ago by Alexander Tsvyashchenko

As far as I understood from comments, adding new functionality like this is not encouraged anymore for 2.4.* kernels - however, personally I needed this functionality for my purposes and upgrading to 2.6-based build is not an option - therefore, I've decided to post this patch anyway - even if it's not included in main tree, it's still possible someone can find it if he needs it and apply on his own.

009-random_and_ROUTE.2.patch was added by mistake, it's the duplicate of previous patch - please remove it.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.