Modify

Opened 7 years ago

Closed 7 years ago

#8734 closed defect (invalid)

wrt160nl with e1820 3g modem usb hangs

Reported by: anonymous Owned by: developers
Priority: high Milestone: Backfire 10.03.1
Component: kernel Version: Trunk
Keywords: e1820 wrt160nl 3g hang Cc: bergkatten@…

Description

All versions since openwrt backfire version 10.03-beta up to bleeding edge, r25094.
The connection with the usb modem hangs in a couple of seconds after initialization.
It may be a driver related problem as the router works on laptops with different distributions.

After ifup wan the system manages get IP address and syncronizes the time.
Then hangs the modem and the following logs appear in dmesg:

------------[ cut here ]------------
WARNING: at drivers/usb/serial/usb-serial.c:394 0x809089e0()
Modules linked in: option usbserial ledtrig_usbdev nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack ehci_hcd pppoe pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc ath9k ath9k_common ath9k_hw ath mac80211 usbcore nls_base crc_ccitt cfg80211 compat_firmware_class compat arc4 aes_generic deflate ecb cbc leds_gpio button_hotplug gpio_buttons input_polldev input_core
Call Trace:[<8007edac>] 0x8007edac
[<8006919c>] 0x8006919c
[<8006919c>] 0x8006919c
[<8007dcb8>] 0x8007dcb8
[<809089e0>] 0x809089e0
[<809089e0>] 0x809089e0
[<801ce3f0>] 0x801ce3f0
[<81b8ece4>] 0x81b8ece4
[<81b8f604>] 0x81b8f604
[<80082f0c>] 0x80082f0c
[<8009334c>] 0x8009334c
[<80083700>] 0x80083700
[<800e20d4>] 0x800e20d4
[<800837e0>] 0x800837e0
[<80083a68>] 0x80083a68
[<8024d31c>] 0x8024d31c
[<801ce984>] 0x801ce984
[<801cea18>] 0x801cea18
[<800db1d0>] 0x800db1d0
[<800d7bd8>] 0x800d7bd8
[<800d7c90>] 0x800d7c90
[<80062544>] 0x80062544
[<800e74fc>] 0x800e74fc

---[ end trace a3812b4f7bec5029 ]---]

Attachments (1)

bug.log (6.3 KB) - added by bergkatten@… 7 years ago.
some relevant logs

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by bergkatten@…

some relevant logs

comment:1 Changed 7 years ago by anonymous

Bug seems to be a feature!
Buying an usb hub with power supply solved the problem. It'd nice if the chat process or the driver told "there is not enough power" for the moden to function properly!

comment:2 Changed 7 years ago by anonymous

The ticket may be closed.
Please mention that a powered usb hub is recommended with wrt160nl here: http://wiki.openwrt.org/doc/recipes/3gdongle

Br

comment:3 Changed 7 years ago by jow

  • Resolution set to invalid
  • Status changed from new to closed

hardware issue

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.