Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8720 closed defect (duplicate)

disabling big file support results in busybox failing to compile

Reported by: Zhang Chi <zhangchi866@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: other Version: Trunk
Keywords: Cc:

Description

Tested targets: ixp4xx, ramips

When support for big files id turned off in general options(in make menuconfig), busybox will fail to compile:

#error It appears you have defined _FILE_OFFSET_BITS=64. Unfortunately, uClibc was built without large file support enabled.

I think this is a mistake in the build system.

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by florian

Though this should not fail, why would you want to disable large file support at all?

comment:2 Changed 7 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #2902

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.