Modify

Opened 7 years ago

Closed 7 years ago

#8714 closed defect (duplicate)

Problem of booting/running Backfire on Cyrix/NatSemi/Geode chipsets 5530/5530A

Reported by: Gordon Freeman <deusex25@…> Owned by: developers
Priority: highest Milestone: Backfire 10.03.1
Component: kernel Version: Backfire 10.03.1 RC4
Keywords: Cyrix, Geode, National Semiconductor, cx5530 Cc:

Description

Gents, I have a problem of booting Backfire 10.03 (x86-combined-squashfs or x86-combined-jffs2 image) on 5530/5530A based embedded boards: SBC MediaGX and Gene4312. Media is 2Gb CompactFlash2. During the boot I'm getting error message like: "can not find device /dev/sda2", then getting "waiting for root device /dev/mtdblock0". After that system hangs up. Kamikatze 8.09 used to boot fine on this boards... I guess, second error message dependant of the first one, and IDE controller / chipset is not supported by the kernel. I found a lot of similar (like this) posts in web, and people recommends to rebuild the kernel with 5530 chipset / IDE controller support. So, I did it, but got the same error again :-( Then I did the experiment: I used this (and original) image build on another embedded board with P1 166 and old VIA chipset. And voila - both system builds (my and original) boots fine, without any problems at all!? If impossible to solve this problem in this release, then I'd like to ask developers to add core support of Cyrix/NatSemi/Geode chipsets (5510/20/30/30A/35/36) for x86 platform by default in next releases. There is a lot of embedded boards, based on this chipsets.

Please, mail me, if you know, how I can sort this problem now. (deusex25(at)gmail(dot)com)

Thanks & regards.

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by jogo

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #8586.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.