Modify

Opened 7 years ago

Last modified 3 years ago

#8697 new enhancement

Fix WLAN LED on the DIR-300A board

Reported by: m2rk@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

Wlan led on that router does not work as should be. Always off. Status LED is used as a wifi indicator instead.

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by igold@…

I have the same issue with LEDs. But I tried workaround from this page https://forum.openwrt.org/viewtopic.php?id=29714 and now I have proper LED for wireless activity. But SYS LED always off now. I hope you'll fix this issue properly to use both LEDs.

comment:2 Changed 6 years ago by dark_skeleton <dark.skeleton@…>

About the System LED, you can turn it on using a cron job :)
Just tell it to run gpioctl at startup, or actually tell it to run two tasks at once:

gpioctl dirout 7 && gpioctl set 7

You can also control that LED as you wish, e.g. let it light up when the router can ping some address and turn it off when there's no Internet access, or even let it blink :)

I'm not sure thought that openwrt's cron supports "on boot"/"on login" tasks, so you could always write a script and put it in /etc/init.d

#!/bin/bash
gpioctl dirout 7 && gpioctl set 7

call it "stled" or something, then

chmod +x stled

, add a symlink to that file in rc.d folder

ln -s stled ../rc.d/S99stled

and voila, and it will run every time you boot your DIR-300. Fairly easy :)

comment:3 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.