Modify

Opened 7 years ago

Closed 7 years ago

#8676 closed defect (duplicate)

Firmware image with NoDogSplash is not accessible with telnet

Reported by: zioproto Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: packages Version: Backfire 10.03.1 RC4
Keywords: capitive portal Cc: contatti@…

Description

If you compile your own firmware image with NoDogSplash package, you will not be able to telnet into the router after flashing.

It is necessary to flash first, set SSH password, and then install NoDogSplash.

This should be fixed changing default configuration of NoDogSplash

Attachments (0)

Change History (5)

comment:1 Changed 7 years ago by isleman

adding

   FirewallRule allow tcp port 23

to FirewallRuleSet users-to-router 'stanza' in build_dir/mipsel/nodogsplash_<something>/nodogsplash.conf should fix.

comment:2 follow-up: Changed 7 years ago by Elphidium

Theres another way, you can login on the web interface (luci) and restart the firewall in the status, firewall tab, theres no need to change config files.

comment:3 in reply to: ↑ 2 ; follow-up: Changed 7 years ago by zioproto

Replying to Elphidium:

Theres another way, you can login on the web interface (luci) and restart the firewall in the status, firewall tab, theres no need to change config files.

if you are compiling a custom firmware you might now want the web interface. So yes, I think it is necessary to change the config files.

comment:4 in reply to: ↑ 3 Changed 7 years ago by zioproto

Replying to zioproto:

Replying to Elphidium:

Theres another way, you can login on the web interface (luci) and restart the firewall in the status, firewall tab, theres no need to change config files.

if you are compiling a custom firmware you might now want the web interface. So yes, I think it is necessary to change the config files.

sorry I meant "you might NOT want the web interface"

comment:5 Changed 7 years ago by swalker

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #8635.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.