Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8654 closed defect (duplicate)

WNDR3700 USB LED broken sysinit

Reported by: JR <oss@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: wndr3700 usb led Cc:

Description

This error has been around for awhile, I don't know if it ever worked. This is on recent trunk r24985

Jan 14 23:11:05 gate user.info sysinit: setting up led WAN LED (green)
Jan 14 23:11:05 gate user.info sysinit: setting up led USB
Jan 14 23:11:05 gate user.info sysinit: usbdev
Jan 14 23:11:05 gate user.info sysinit: /etc/rc.common: eval: line 1: can't create /sys/class/leds/wndr3700:green:usb/device_name: nonexistent directory
Jan 14 23:11:05 gate user.info sysinit: /etc/rc.common: eval: line 1: can't create /sys/class/leds/wndr3700:green:usb/activity_interval: nonexistent directory

USB LED never lights up, even when USB in use or populated.

root@gate:~# dmesg|grep "Registered led"
Registered led device: wndr3700:green:power
Registered led device: wndr3700:orange:power
Registered led device: wndr3700:green:wps
Registered led device: wndr3700:orange:wps
Registered led device: wndr3700:green:wan
Registered led device: ath9k-phy0
Registered led device: ath9k-phy1
Registered led device: wndr3700:green:usb

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by JR <oss@…>

Appears to be looking in the wrong location under /sys

root@gate:/sys# find /sys -name "*wndr3700*" -print
/sys/devices/platform/leds-gpio/leds/wndr3700:green:power
/sys/devices/platform/leds-gpio/leds/wndr3700:orange:power
/sys/devices/platform/leds-gpio/leds/wndr3700:green:wps
/sys/devices/platform/leds-gpio/leds/wndr3700:orange:wps
/sys/devices/platform/leds-gpio/leds/wndr3700:green:wan
/sys/devices/platform/wndr3700-led-usb
/sys/devices/platform/wndr3700-led-usb/leds/wndr3700:green:usb
/sys/bus/platform/devices/wndr3700-led-usb
/sys/bus/platform/drivers/wndr3700-led-usb
/sys/bus/platform/drivers/wndr3700-led-usb/wndr3700-led-usb
/sys/class/leds/wndr3700:green:power
/sys/class/leds/wndr3700:orange:power
/sys/class/leds/wndr3700:green:wps
/sys/class/leds/wndr3700:orange:wps
/sys/class/leds/wndr3700:green:wan
/sys/class/leds/wndr3700:green:usb
/sys/module/leds_wndr3700_usb
/sys/module/leds_wndr3700_usb/drivers/platform:wndr3700-led-usb

comment:2 Changed 7 years ago by JR <oss@…>

root@gate:/sys/devices/platform/wndr3700-led-usb/leds/wndr3700:green:usb# ls -l
-rw-r--r--    1 root     root          4096 Jan 14 23:11 brightness
lrwxrwxrwx    1 root     root             0 Jan 14 23:34 device -> ../../../wndr3700-led-usb
-r--r--r--    1 root     root          4096 Jan 14 23:34 max_brightness
lrwxrwxrwx    1 root     root             0 Jan 14 23:34 subsystem -> ../../../../../class/leds
-rw-r--r--    1 root     root          4096 Jan 14 23:11 trigger
-rw-r--r--    1 root     root          4096 Jan 14 23:34 uevent

comment:3 Changed 7 years ago by juhosg

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #8622.

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.