Modify

Opened 11 years ago

Closed 11 years ago

Last modified 4 years ago

#865 closed defect (fixed)

lighttpd fails to compile: cannot find -lpcre

Reported by: MMCM Owned by: nico
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:

Description

R5227 (not 5161)

mipsel-linux-uclibc-gcc -DHAVE_CONFIG_H -DLIBRARY_DIR=\"/usr/lib/lighttpd\" -I. -I. -I.. -I/srv/devel/openwrt-5161/trunk/staging_dir_mipsel/usr/include/libxml2 -I/srv/devel/openwrt-5161/trunk/staging_dir_mipsel/usr/include -I/srv/devel/openwrt-5161/trunk/staging_dir_mipsel/include -D_REENTRANT -DEXTENSIONS -I/srv/devel/openwrt-5161/trunk/staging_dir_mipsel/usr/include -DOPENSSL_NO_KRB5 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGE_FILES -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -Wall -W -Wshadow -pedantic -MT mod_trigger_b4_dl.lo -MD -MP -MF .deps/mod_trigger_b4_dl.Tpo -c mod_trigger_b4_dl.c -o mod_trigger_b4_dl.o >/dev/null 2>&1

/bin/sh ../libtool --tag=CC --mode=link mipsel-linux-uclibc-gcc -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -Wall -W -Wshadow -pedantic -L/srv/devel/openwrt-5161/trunk/staging_dir_mipsel/usr/lib -L/srv/devel/openwrt-5161/trunk/staging_dir_mipsel/lib -L/srv/devel/openwrt-5161/trunk/staging_dir_mipsel/usr/lib -o mod_trigger_b4_dl.la -rpath /usr/lib/lighttpd -module -export-dynamic -avoid-version -no-undefined mod_trigger_b4_dl.lo -L/srv/devel/openwrt-5161/trunk/staging_dir_mipsel/usr/lib -lpcre
mipsel-linux-uclibc-gcc -shared .libs/mod_trigger_b4_dl.o -L/srv/devel/openwrt-5161/trunk/staging_dir_mipsel/usr/lib -L/srv/devel/openwrt-5161/trunk/staging_dir_mipsel/lib -lpcre -mips32 -mtune=mips32 -Wl,-soname -Wl,mod_trigger_b4_dl.so -o .libs/mod_trigger_b4_dl.so
/srv/devel/openwrt-5161/trunk/staging_dir_mipsel/lib/gcc/mipsel-linux-uclibc/3.4.6/../../../../mipsel-linux-uclibc/bin/ld: cannot find -lpcre
collect2: ld returned 1 exit status

Package libpcre is selected with "M".

I have similar problems with other packages, e.g. PHP4

Attachments (0)

Change History (6)

comment:1 Changed 11 years ago by nico

  • Owner changed from developers to nico
  • Status changed from new to assigned

The libpcre.so alias was not installed during InstallDev, that was fixed in [5162].
Try the following:

$ make package/pcre-clean
$ make package/pcre-compile

comment:2 Changed 11 years ago by MMCM

Sorry, but that didn't help. Still the same error.

I looked at my local copy of the Makefile for pcre, and it's still the old version. Strange, because I upgraded to the latest version with "svn co https://svn.openwrt.org/openwrt/trunk/". Or do I have to start over from scratch?
Or any other known problems there?

Anyway, I manually upgraded the Makefile, ran the above command, and it works now.

Thanks a lot.

comment:3 Changed 11 years ago by MMCM

Well, it seems I upgraded only the trunk directory, forgetting packages...

comment:4 Changed 11 years ago by nico

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:5 Changed 10 years ago by salimsaay

when i am compiling wpa_supplicant-0.4.7 with cross-compiler, i see this message " mipsel-linux-uclibc/bin/ld: cannot find -lssl
is any one to help me.

i am using OpenWrt, Wrt54gl and i compiling the package through SDK cross-cross compiler.

thanks for any help
if any body know by detail can send to my E-mail salimsaay@…

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.