Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8638 closed defect (wontfix)

Backfire + Madwifi txpower problem

Reported by: huey07@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: Backfire 10.03.1 RC4
Keywords: Madwifi iwlist Cc:

Description

When running an 'atheros' image w/ Madwifi on an ECB-3500 'wifi restart' will cause issues with txpower being shown. I had gotten around this by unloading the modules on 'disable_atheros' and inserting again on 'enable_atheros'. As ugly as that was it fixed the problem until I tried my build on an EAP-3660, then the 'wifi restart' lock the sytem up. Unfortunately ath5k in trunk won't initialize my devices either.

root@router:~# iwlist ath0 txpower
ath0      8 available transmit-powers :
          0 dBm         (1 mW)
          2 dBm         (1 mW)
          4 dBm         (2 mW)
          6 dBm         (3 mW)
          8 dBm         (6 mW)
          10 dBm        (10 mW)
          12 dBm        (15 mW)
          14 dBm        (25 mW)
          Current Tx-Power=14 dBm       (25 mW)

root@router:~# wifi restart
root@router:~# iwlist ath0 txpower
ath0      8 available transmit-powers :
          0 dBm         (1 mW)
          3 dBm         (1 mW)
          4 dBm         (2 mW)
          5 dBm         (3 mW)
          6 dBm         (3 mW)
          7 dBm         (5 mW)
          8 dBm         (6 mW)
          9 dBm         (7 mW)
          Current Tx-Power=9 dBm        (7 mW)
cat /etc/config/wireless
config 'wifi-device' 'wifi0'
        option 'type' 'atheros'
        option 'antenna' 'vertical'
        option 'diversity' '0'
        option 'country' '840'
        option 'rxantenna' '0'
        option 'txantenna' '0'
        option 'channel' '06'
        option 'txpower' '14'

config 'wifi-iface'
        option 'device' 'wifi0'
        option 'network' 'ssid1'
        option 'mode' 'ap'
        option 'ssid' 'OpenWrt'
        option 'encryption' 'none'

Attachments (0)

Change History (5)

comment:1 follow-up: Changed 7 years ago by anonymous

I am experiencing a similar problem with madwifi on my ixp4xx (on both Backfire and trunk builds). The "iwlist ath0 txpower" output produces different results between wifi restarts... which is also causing problems in the LuCI networking wifi configuration page (as it populates the drop-down-box with the available transmit-powers).

Sometimes I get no result from the txpower output (reports 0), other times I get different results (i.e. one time it said max avail power was 19 dBm, then another time it said max avail power was 15 dBm).

comment:2 Changed 7 years ago by huey07@…

Mine follows the same path as yours, seems to go down by 5dbm, until it reaches 0. Usually a restart or reloading of the modules fixes the issue for me. I'll keep trying to hunt down the root of this problem and i'll update if I find it.

comment:3 in reply to: ↑ 1 Changed 7 years ago by anonymous

Would you be able to identify the model/chipset of the card?

Replying to anonymous:

I am experiencing a similar problem with madwifi on my ixp4xx (on both Backfire and trunk builds). The "iwlist ath0 txpower" output produces different results between wifi restarts... which is also causing problems in the LuCI networking wifi configuration page (as it populates the drop-down-box with the available transmit-powers).

Sometimes I get no result from the txpower output (reports 0), other times I get different results (i.e. one time it said max avail power was 19 dBm, then another time it said max avail power was 15 dBm).

comment:4 Changed 7 years ago by nbd

  • Resolution set to wontfix
  • Status changed from new to closed

madwifi development has stopped, consider switching to ath5k

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.