Modify

Opened 7 years ago

Closed 7 years ago

#8635 closed enhancement (wontfix)

nodogsplash locks the router on fresh install

Reported by: duvi Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: packages Version: Trunk
Keywords: Cc:

Description

I built the latest trunk with nodogsplash for a Fonera.
This device has only one ethernet port, which is in network 'lan' by default.

Nodogsplash enables captive portal on this interface by default, so you can only connect on TCP ports 22, 80, 443 to the router.

But on a fresh install ssh/dropbear is not available until you telnet to the router and set a root password. Since TCP port 23 is not opened by nodogsplash, basically you can do nothing (unless use Luci).

This patch opens TCP port 23 also by default in nodogsplash.conf, so telnet connection will be available.

Place it in feeds/packages/net/nodogsplash/patches

Please also add it to OpenWrt trunk!

Attachments (1)

001-firewall_enable_telnet.patch (296 bytes) - added by duvi 7 years ago.

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by duvi

comment:1 Changed 7 years ago by jow

  • Resolution set to wontfix
  • Status changed from new to closed

If you use custom images with dropbear embedded you can also just embed a password as well, if you install dropbear with opkg you already have shell access to set a password and last but not least there's also failsafe if your really lock yourself out during setup, therfore I fail to see the purpose here.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.