Modify

Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#8626 closed defect (duplicate)

DynDNS OVH Update doesn't work

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Backfire 10.03.1 RC4
Keywords: Cc:

Description

Hi all,

I get every time an error by updating a dynamic dns with OVH service.

I customized /usr/lib/ddns/services script:
"www.ovh.com" "http://[USERNAME]:[PASSWORD]@www.ovh.com/nic/update?system=dyndns&hostname=[DOMAIN]&myip=[IP]"

On a 10.03.1 RC4 I get an error:
"wget: server returned error: HTTP/1.1 401 Authorization Required"

The same setup is working with 10.03 version

My /etc/config/ddns looks like this:

config 'service' 'ovh'

option 'check_interval' '10'
option 'check_unit' 'minutes'
option 'force_interval' '72'
option 'force_unit' 'hours'
option 'enabled' '1'
option 'service_name' 'www.ovh.com'
option 'domain' 'test.domain.name'
option 'username' 'domain.name-test'
option 'password' 'password'
option 'ip_source' 'network'
option 'ip_network' 'wan'

what could be wrong?? is it possible wget can't auth by ovh???

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by anonymous

Hi all,

I think the problem is similar to the ticket #6566.
I have a "!" sign in the password, and it will be changed to "25%c" for url updating script.

comment:2 Changed 7 years ago by anonymous

but should be %21 for exclamination mark

comment:3 Changed 6 years ago by swalker

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #7607.

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.