Modify

Opened 7 years ago

Closed 5 years ago

Last modified 4 years ago

#8625 closed defect (fixed)

RT3070 failed at the high data rate

Reported by: r32190@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description

Platform is BRCM6538, using the r24903 and previous branch, several RT3070 USB adapters at station mode works fine with ping. When downloading file from remote AP, system crashes with following message (some data omitted):

{{{Unable to handle kernel paging request at virtual address 000000a0, epc == 81a8c1ec, ra == 81a86c48
Oops#1:
Cpu 0
$ 0 : 00000000 10008400 00000010 00000002

...

$28 : 81ade000 81adfe18 00000000 81a86c48
Hi : 000001f4
Lo : 0000000c
epc : 81a8c1ec 0x81a8c1ec

Not tainted

ra : 81a86c48 0x81a86c48
Status: 10008403 KERNEL EXL IE
Cause : 00800008
BadVA : 000000a0
PrId : 0002a010 (Broadcom BCM6358)
Modules linked in: gpio_buttons nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack pppoe pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc b43 rt2800usb rt2800lib rt2x00usb rt2x00lib ehci_hcd mac80211 usbcore nls_base input_polldev crc_itu_t crc_ccitt cfg80211 compat input_core arc4 aes_generic deflate ecb cbc switch_adm switch_robo switch_core
Process phy0 (pid: 529, threadinfo=81ade000, task=81a14a28, tls=00000000)
Stack : 00

...

Call Trace:[<81 ....

Code: 8c .....
Disabling lock debugging due to kernel taint " }}}

No problem using RT2870 (Samsung WIS09ABGN). The failure is easy to reproduce and consistent.

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.