Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8600 closed defect (fixed)

TP-Link TL-WN961N v1.2 (AR5416-AC1A) + ath9k: reboot on concurrent wifi connections

Reported by: zolfa@… Owned by: developers
Priority: high Milestone: Backfire 10.03.1
Component: kernel Version: Trunk
Keywords: Cc:

Description

Hardware configuration:
Asus WL-500g Premium v1
MiniPCI WifiCard: TP-Link TL-WN961N v1.2 (chipset AR5416-AC1A)

Software configuration:
Backfire SVN (10.03, r24824)
Kernel 2.6.32.27
kmod-ath9k,kmod-ath,kmod-cfg80211 2.6.32.27+2010-12-16-2
wpad-mini - 20100705-2
WiFi: 11ng-mode, with none encryption and with psk2-ccmp encryption
(ipkg list-installed attached)

Problem description:
When i have many concurrent tcp/udp connections through wifi (also in g-only mode) the router crashes (no inet services, no ping, no wifi) and sometimes reboots itself.
Logging with "logread -f" from ssh hasn't given me anything to debug this problem.
I am able to reproduce this bug opening from a Win or Linux client (wifi-connected, g or n) a SMB folder from my wired NAS with many (20+) pictures: I think that loading previews makes my router crash.
With single HTTP/FTP file transfer I do not have any problem (1GB+ file transfer without any problem) and also www navigation is ok.
At the moment of the crash CPU and RAM usage seems normal.
I haven't tried if using madwifi fix this problem, but I've bought this card only for 11n, so I would like to use ath9k.

Attached files:
opkg.txt - output of "opkg list-installed"
iw.txt - output of "iw list"
dmesg.txt - a typical "dmesg" of my running router
wifi.txt - /etc/config/wireless
hostapd.txt - /var/run/hostapd-phy0.conf
(in the present configuration I have 2 different SSIDs, wep&wpa, the problem is still present with only 1 SSID and no encryption).

Currently I'm not able to get a serial interface for a more accurate debug, with "logread -f" the connection crashed before i was able to get anything.

However while the router is working the connection is quite good (130mbps, great signal strength).

Attachments (5)

dmesg.txt (11.6 KB) - added by zolfa@… 7 years ago.
# dmesg
iw.txt (2.7 KB) - added by zolfa@… 7 years ago.
# iw list
hostapd.txt (1.3 KB) - added by zolfa@… 7 years ago.
# cat /var/run/hostapd-phy0.conf
opkg.txt (1.7 KB) - added by zolfa@… 7 years ago.
# opkg list-installed
wifi.txt (729 bytes) - added by zolfa@… 7 years ago.
# cat /etc/config/wireless

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by zolfa@…

# dmesg

Changed 7 years ago by zolfa@…

# iw list

Changed 7 years ago by zolfa@…

# cat /var/run/hostapd-phy0.conf

Changed 7 years ago by zolfa@…

# opkg list-installed

Changed 7 years ago by zolfa@…

# cat /etc/config/wireless

comment:1 Changed 7 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

should be fixed in the upcoming 10.03.1-rc5

comment:2 Changed 7 years ago by zolfa@…

I'll try again as soon as possible (in the next 2 months), thank you for your attention

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.