Modify

Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#8593 closed defect (fixed)

rev 24920 breaks backfire xtables-addons compile

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: packages Version: Backfire 10.03.1 RC4
Keywords: xtables-addons compile backfire Cc:

Description

rev 24920 breaks backfire xtables-addons compile

make[4]: Entering directory `/mnt/systemdisk/openwrt/Routerstationpro-openwrt-backfire/build_dir/linux-ar71xx/xtables-addons-1.31'
CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/bash /mnt/systemdisk/openwrt/Routerstationpro-openwrt-backfire/build_dir/linux-ar71xx/xtables-addons-1.31/missing --run aclocal-1.11 -I m4
configure.ac:31: /mnt/systemdisk/openwrt/Routerstationpro-openwrt-backfire/staging_dir/host/bin/m4: Warning: excess arguments to builtin `m4_if' ignored
autom4te: /mnt/systemdisk/openwrt/Routerstationpro-openwrt-backfire/staging_dir/host/bin/m4 failed with exit status: 1
aclocal-1.11: autom4te failed with exit status: 1
make[4]: *** [aclocal.m4] Error 1
make[4]: Leaving directory `/mnt/systemdisk/openwrt/Routerstationpro-openwrt-backfire/build_dir/linux-ar71xx/xtables-addons-1.31'
make[3]: *** [/mnt/systemdisk/openwrt/Routerstationpro-openwrt-backfire/build_dir/linux-ar71xx/xtables-addons-1.31/.built] Error 2
make[3]: Leaving directory `/mnt/systemdisk/openwrt/Routerstationpro-openwrt-backfire/feeds/packages/net/xtables-addons'
make[2]: *** [package/feeds/packages/xtables-addons/compile] Error 2
make[2]: Leaving directory `/mnt/systemdisk/openwrt/Routerstationpro-openwrt-backfire'
make[1]: *** [/mnt/systemdisk/openwrt/Routerstationpro-openwrt-backfire/staging_dir/target-mips_r2_uClibc-0.9.30.1/stamp/.package_compile] Error 2
make[1]: Leaving directory `/mnt/systemdisk/openwrt/Routerstationpro-openwrt-backfire'
make: *** [world] Error 2

Attachments (1)

003-redundant-bracket.patch (419 bytes) - added by anonymous 7 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by jow

This error is completely unrelated. Also please provide more context, the above log does not reveal the root cause.

comment:2 Changed 7 years ago by anonymous

I don't know what to provide.

Strangely it do compile(for me) without the 002-fix-kernel-version-detection.patch.

When looking at the configure.ac:31, It seemed that it contained a superfluous ] bracket after "autodetect"?, so I manually removed the last ] bracket (just after the compile error) and then it compiled fine.

I don't know if this is related at all beacause configure.ac has exactly the same brackets without the 002 patch, but compiles without error.

AC_ARG_WITH([xtlibdir],
        AS_HELP_STRING([--with-xtlibdir=PATH],
        [Path where to install Xtables extensions [[autodetect]]]]),
        [xtlibdir="$withval"])

Changed 7 years ago by anonymous

comment:3 follow-up: Changed 7 years ago by reuben.m@…

Same issue here.

comment:4 in reply to: ↑ 3 Changed 7 years ago by anonymous

Replying to reuben.m@…:

Same issue here.

This fix worked for me too.

comment:5 Changed 7 years ago by Chillifire

Same issue here on atheros MIPS

comment:6 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

Committed in r25033 - thanks!

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.