Modify

Opened 7 years ago

Closed 7 years ago

#8575 closed defect (worksforme)

OpenVPN not working in ethernet bridging without selfcreated scripts

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: packages Version: Backfire 10.03.1 RC4
Keywords: openvpn tap bridge Cc:

Description

Hi,

I'm currently trying to get OpenVPN up and running on my WNDR3700. I'm on Backfire 10.03.1-rc4 and installed "luci-app-opvenvpn".

I could setup the vpn using the web interface. I want to make use of the "tap" mode, which seems to be not that much used (compared to the issues with tun mode I found when searching for it).

Maybe I've done something totally wrong or didn't find a feature for this, however there is a script missing (which is in the documentation of OpenVPN (see: http://openvpn.net/index.php/open-source/documentation/miscellaneous/76-ethernet-bridging.html).

So, basically the tap device has to be added to the bridge.

I found this old forum thread from 2005: https://forum.openwrt.org/viewtopic.php?id=1800

I just had to change "br0" to "br-lan", which makes it possible for me to connect to my VPN from outside.

However I can't reach it with a simple ping (neither from the client itself, nor from any client within the lan). I guess it must be a routing issue, or something like this, although I have to investigate this in some more detail.

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce the issue here. The way to go is using a fixed ifname and add it to the lan bridge ifname(es), no scripts needed.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.