Modify

Opened 7 years ago

Closed 7 years ago

#8573 closed defect (worksforme)

package firewall is unremovable

Reported by: Brian J. Murrell <brian@…> Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: base system Version: Backfire 10.03.1 RC4
Keywords: Cc:

Description

I just tried to remove the firewall package since I prefer the much more comprehensive shorewall[-lite in my case]. That's not meant to be a knock on the firewall package as it's entirely suitable for less demanding situations that mine.

However there is a dependency chain that results in removing the luci base package if you want to remove firewall since luci-app-firewall depends on firewall and luci depends on luci-app-firewall.

One really ought to be able to remove firewall (and probably luci-app-firewall) without having to remove luci altogether.

Thots?

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

It is removable just fine. "luci" is an empty meta package which groups various components and "luci-app-firewall" is the gui frontend for "firewall". It is perfectly reasonable behaviour that those get removed as the dependency to "firewall" is not satisfied anymore.

Uninstalling "luci" and "luci-app-firewall" will *not* uninstall the whole gui.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.