Modify

Opened 7 years ago

Last modified 4 years ago

#8570 new defect

dhcp6 server does not need libncurses

Reported by: roman.yepishev@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

Installing dhcp6-server (1.0-1) to root...
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for dhcp6-server:
 * 	libncurses * 
 * opkg_install_cmd: Cannot install package dhcp6-server.

libncurses adds more than 100Kb to the image and none of its functionality is used by dhcp6-server.

Reason:

 define Package/dhcp6/Default
   SECTION:=ipv6
   CATEGORY:=IPv6
   DEPENDS:=+libncurses
   TITLE:=IPv6 DHCP
   URL:=http://sourceforge.net/projects/dhcpv6-linux
 endef

The fix is to remove DEPENDS:=+libncurses from Default section and add it into server-specific ones.

Attachments (1)

dhcp6-server-no-ncurses.patch (499 bytes) - added by roman.yepishev@… 7 years ago.
move DEPENDS to dhcp6-client

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by roman.yepishev@…

move DEPENDS to dhcp6-client

comment:1 Changed 7 years ago by Roman Yepishev <roman.yepishev@…>

Don't know whether that will help that package though, since the configurability of dhcp6-server is far from being understandable and it looks like that lacks DNS info support. So this can be marked as very low priority.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.