Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8561 closed defect (duplicate)

Trunk fails to compile - error in e2fsprogs

Reported by: andrew.lyon@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Building trunk r24865 compile errors at e2fsprogs:

make[6]: Leaving directory `/mnt/store/admin/trunk/build_dir/target-mips_uClibc-0.9.31/e2fsprogs-1.41.14/lib/blkid'
making all in intl
make[6]: Entering directory `/mnt/store/admin/trunk/build_dir/target-mips_uClibc-0.9.31/e2fsprogs-1.41.14/intl'
make[6]: Nothing to be done for `all'.
make[6]: Leaving directory `/mnt/store/admin/trunk/build_dir/target-mips_uClibc-0.9.31/e2fsprogs-1.41.14/intl'
making all in e2fsck
make[6]: Entering directory `/mnt/store/admin/trunk/build_dir/target-mips_uClibc-0.9.31/e2fsprogs-1.41.14/e2fsck'

LD e2fsck

../lib/libext2fs.so: warning: the use of OBSOLESCENT utime' is discouraged, use utimes'
../lib/libext2fs.so: undefined reference to `posix_memalign'
collect2: ld returned 1 exit status
make[6]: * [e2fsck] Error 1
make[6]: Leaving directory `/mnt/store/admin/trunk/build_dir/target-mips_uClibc-0.9.31/e2fsprogs-1.41.14/e2fsck'
make[5]:
* [all-progs-recursive] Error 1
make[5]: Leaving directory `/mnt/store/admin/trunk/build_dir/target-mips_uClibc-0.9.31/e2fsprogs-1.41.14'
make[4]: * [all] Error 2
make[4]: Leaving directory `/mnt/store/admin/trunk/build_dir/target-mips_uClibc-0.9.31/e2fsprogs-1.41.14'
make[3]:
* /mnt/store/admin/trunk/build_dir/target-mips_uClibc-0.9.31/e2fsprogs-1.41.14/.built Error 2
make[3]: Leaving directory `/mnt/store/admin/trunk/package/e2fsprogs'
make[2]: * [package/e2fsprogs/compile] Error 2
make[2]: Leaving directory `/mnt/store/admin/trunk'
make[1]:
* /mnt/store/admin/trunk/staging_dir/target-mips_uClibc-0.9.31/stamp/.package_compile Error 2
make[1]: Leaving directory `/mnt/store/admin/trunk'
make: * [world] Error 2

Attachments (1)

buildlog.zip (419.2 KB) - added by andrew.lyon@… 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by andrew.lyon@…

comment:1 Changed 7 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #8550

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.