Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8549 closed defect (invalid)

Netgear WGT634U busted again, no ethernet

Reported by: seniorr@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

r23911 okay
r24196 okay
r24264 okay
r24513 bad
r24748 bad
r24843 bad

where "bad" means that during boot, I am seeing this:

b44: Invalid MAC address found in EEPROM
b44 ssb0:0: Problem fetching invariants of chip, aborting
b44: probe of ssb0:0 failed with error -22

and I have no ethernet interfaces.

I see Changeset 24749 was perhaps intended to address this problem, but as r24843 indicates, the problem persists. I suspect the problem is r24266 (testing now). On WGT634U, you *must* query CFE because the macaddr information is not present in the area of flash that the nvram reading infrastructure looks at. Or you must fix the nvram reading infrastructure to look in the right place. At least, that's my theory.

Attachments (0)

Change History (6)

comment:1 Changed 7 years ago by seniorr@…

gah, the messages should be:

b44: Invalid MAC address found in EEPROM
b44 ssb0:0: Problem fetching invariants of chip, aborting
b44: probe of ssb0:0 failed with error -22

comment:2 Changed 7 years ago by seniorr@…

As suspected, r24266 is the bad one.

comment:3 Changed 7 years ago by seniorr@…

Here is a hexdump -C of /dev/mtdblock4 (where the CFE/nvram data are stored):

00000000  ff ff ff ff ff ff ff ff  ff ff ff ff ff ff ff ff  |................|
*
00018000  46 4c 53 48 2c 00 00 00  50 01 19 04 00 00 40 80  |FLSH,...P.....@.|
00018010  00 00 00 00 73 64 72 61  6d 5f 6e 63 64 6c 3d 30  |....sdram_ncdl=0|
00018020  78 30 30 30 32 30 30 38  30 00 00 00 ff ff ff ff  |x00020080.......|
00018030  ff ff ff ff ff ff ff ff  ff ff ff ff ff ff ff ff  |................|
*
0001e000  01 14 00 62 6f 61 72 64  74 79 70 65 3d 62 63 6d  |...boardtype=bcm|
0001e010  39 35 33 36 35 72 01 0d  00 65 74 30 6d 64 63 70  |95365r...et0mdcp|
0001e020  6f 72 74 3d 30 01 0f 00  65 74 30 70 68 79 61 64  |ort=0...et0phyad|
0001e030  64 72 3d 32 35 34 01 51  00 53 54 41 52 54 55 50  |dr=254.Q.STARTUP|
0001e040  3d 69 66 63 6f 6e 66 69  67 20 65 74 68 30 20 2d  |=ifconfig eth0 -|
0001e050  61 64 64 72 3d 31 39 32  2e 31 36 38 2e 31 2e 31  |addr=192.168.1.1|
0001e060  20 2d 6d 61 73 6b 3d 32  35 35 2e 32 35 35 2e 32  | -mask=255.255.2|
0001e070  35 35 2e 30 3b 62 6f 6f  74 20 2d 65 6c 66 20 66  |55.0;boot -elf f|
0001e080  6c 61 73 68 30 2e 6f 73  3a 01 4e 00 6b 65 72 6e  |lash0.os:.N.kern|
0001e090  65 6c 5f 61 72 67 73 3d  63 6f 6e 73 6f 6c 65 3d  |el_args=console=|
0001e0a0  74 74 79 53 31 2c 31 31  35 32 30 30 20 72 6f 6f  |ttyS1,115200 roo|
0001e0b0  74 3d 2f 64 65 76 2f 72  61 6d 30 20 69 6e 69 74  |t=/dev/ram0 init|
0001e0c0  3d 2f 6c 69 6e 75 78 72  63 20 72 77 20 73 79 73  |=/linuxrc rw sys|
0001e0d0  74 5f 73 69 7a 65 3d 38  4d 01 0f 00 63 6f 6e 66  |t_size=8M...conf|
0001e0e0  69 67 76 6c 61 6e 3d 30  78 31 01 1d 00 65 74 30  |igvlan=0x1...et0|
0001e0f0  6d 61 63 61 64 64 72 3d  30 30 2d 30 66 2d 62 35  |macaddr=00-0f-b5|
0001e100  2d 30 65 2d 36 61 2d 37  62 01 1d 00 65 74 31 6d  |-0e-6a-7b...et1m|
0001e110  61 63 61 64 64 72 3d 30  30 2d 30 66 2d 62 35 2d  |acaddr=00-0f-b5-|
0001e120  30 65 2d 36 61 2d 37 63  00 38 2e 31 2e 31 20 2d  |0e-6a-7c.8.1.1 -|
0001e130  6d 61 73 6b 3d 32 35 35  2e 32 35 35 2e 32 35 35  |mask=255.255.255|
0001e140  2e 30 3b 62 6f 6f 74 20  2d 65 6c 66 20 66 6c 61  |.0;boot -elf fla|
0001e150  73 68 30 2e 6f 73 3a 00  ff ff ff ff ff ff ff ff  |sh0.os:.........|
0001e160  ff ff ff ff ff ff ff ff  ff ff ff ff ff ff ff ff  |................|
*
00020000

comment:4 Changed 7 years ago by seniorr@…

Turns out the patch in r24749 had not actually been applied when I built r24843. A clean recompile of the kernel fixed the problem. Why it didn't get applied is perhaps the relevant question. Otherwise, please close this ticket and sorry for the bother.

comment:5 Changed 7 years ago by jow

  • Resolution set to invalid
  • Status changed from new to closed

closed due to user request

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.