Modify

Opened 7 years ago

Last modified 4 years ago

#8546 accepted defect

nat reflection doesn't work from the OpenWRT system itself

Reported by: candrews@… Owned by: jow
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

nat reflection works great from the LAN side of the OpenWRT router (woo hoo!).

However, it does not work from the OpenWRT router itself.

For example:

root@OpenWrt:~# curl http://www.integralblue.com/
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="refresh" content="0; URL=/cgi-bin/luci" />
</head>
<body style="background-color: black">
<a style="color: white; text-decoration: none" href="/cgi-bin/luci">LuCI - Lua Configuration Interface</a>
</body>
</html>

However, that should have gotten me the HTML for www.integralblue.com (which works outside the router / on the Internet, and behind the router due to NAT reflection).

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by jow

  • Owner changed from developers to jow
  • Status changed from new to accepted

comment:2 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as accepted .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.