Modify

Opened 7 years ago

Closed 7 years ago

#8538 closed defect (fixed)

ath5k does not emit electoric waves after r24505 on backfire. (also trunk)

Reported by: zukky@… Owned by: developers
Priority: high Milestone: Backfire 10.03.1
Component: kernel Version: Trunk
Keywords: ath5k Cc:

Description

Hi.

My environment is
Gateworks avila gw2348-4 and wistron dcma-82 miniPCI ar5414

After r24505, ath5k on backfire does not emit electoric waves though
it seems miniPCI module is detected

root@OpenWrt:/# iw phy0 info
Wiphy phy0

Band 1:

Frequencies:

  • 2412 MHz [1] (27.0 dBm)
  • 2417 MHz [2] (27.0 dBm)
  • 2422 MHz [3] (27.0 dBm)
  • 2427 MHz [4] (27.0 dBm)
  • 2432 MHz [5] (27.0 dBm)
  • 2437 MHz [6] (27.0 dBm)
  • 2442 MHz [7] (27.0 dBm)
  • 2447 MHz [8] (27.0 dBm)
  • 2452 MHz [9] (27.0 dBm)
  • 2457 MHz [10] (27.0 dBm)
  • 2462 MHz [11] (27.0 dBm)
  • 2467 MHz [12] (disabled)
  • 2472 MHz [13] (disabled)
  • 2484 MHz [14] (disabled)

Bitrates (non-HT):

  • 1.0 Mbps
  • 2.0 Mbps (short preamble supported)
  • 5.5 Mbps (short preamble supported)
  • 11.0 Mbps (short preamble supported)
  • 6.0 Mbps
  • 9.0 Mbps
  • 12.0 Mbps
  • 18.0 Mbps
  • 24.0 Mbps
  • 36.0 Mbps
  • 48.0 Mbps
  • 54.0 Mbps

Band 2:

Frequencies:

  • 5180 MHz [36] (17.0 dBm)
  • 5200 MHz [40] (17.0 dBm)
  • 5220 MHz [44] (17.0 dBm)
  • 5240 MHz [48] (17.0 dBm)
  • 5260 MHz [52] (20.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5280 MHz [56] (20.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5300 MHz [60] (20.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5320 MHz [64] (20.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5500 MHz [100] (20.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5520 MHz [104] (20.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5540 MHz [108] (20.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5560 MHz [112] (20.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5580 MHz [116] (20.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5600 MHz [120] (disabled)
  • 5620 MHz [124] (disabled)
  • 5640 MHz [128] (disabled)
  • 5660 MHz [132] (20.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5680 MHz [136] (20.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5700 MHz [140] (20.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5745 MHz [149] (30.0 dBm)
  • 5765 MHz [153] (30.0 dBm)
  • 5785 MHz [157] (30.0 dBm)
  • 5805 MHz [161] (30.0 dBm)
  • 5825 MHz [165] (30.0 dBm)

Bitrates (non-HT):

  • 6.0 Mbps
  • 9.0 Mbps
  • 12.0 Mbps
  • 18.0 Mbps
  • 24.0 Mbps
  • 36.0 Mbps
  • 48.0 Mbps
  • 54.0 Mbps

max # scan SSIDs: 4
max scan IEs length: 149749760 bytes
Coverage class: 0 (up to 0m)
Supported interface modes:

  • IBSS
  • managed
  • AP
  • AP/VLAN
  • monitor
  • mesh point

Supported commands:

  • new_interface
  • set_interface
  • new_key
  • new_beacon
  • new_station
  • new_mpath
  • set_mesh_params
  • set_bss
  • authenticate
  • associate
  • deauthenticate
  • disassociate
  • join_ibss
  • Unknown command (68)
  • remain_on_channel
  • set_tx_bitrate_mask
  • action
  • Unknown command (67)
  • set_wiphy_netns
  • set_channel
  • Unknown command (66)
  • connect
  • disconnect

Supported TX frame types:

  • IBSS: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • managed: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • AP: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • AP/VLAN: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • (null): 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • (null): 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0

Supported RX frame types:

  • IBSS: 0x00d0
  • managed: 0x0040 0x00d0
  • AP: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
  • AP/VLAN: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
  • (null): 0x0040 0x00d0
  • (null): 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0

root@OpenWrt:/# ifconfig
br-lan Link encap:Ethernet HWaddr 00:0B:6B:2C:15:72

inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:72 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:21524 (21.0 KiB) TX bytes:0 (0.0 B)

eth1 Link encap:Ethernet HWaddr 00:D0:12:13:44:69

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:125 errors:0 dropped:0 overruns:0 frame:0
TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:26610 (25.9 KiB) TX bytes:402 (402.0 B)

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

mon.wlan0 Link encap:UNSPEC HWaddr 00-0B-6B-2C-15-72-00-00-00-00-00-00-00-00-00-00

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:53 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3353 (3.2 KiB) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr 00:0B:6B:2C:15:72

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:71 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:23718 (23.1 KiB)

root@OpenWrt:/# cat /etc/config/wireless
config wifi-device radio0

option type mac80211
option channel 1
option macaddr 00:0b:6b:2c:15:72
option hwmode 11g

# REMOVE THIS LINE TO ENABLE WIFI:

# option disabled 1

config wifi-iface

option device radio0
option network lan
option mode ap
option ssid OpenWrt
option encryption none

config wifi-device radio1

option type mac80211
option channel 11
option macaddr 00:15:6d:65:3e:70
option hwmode 11g

# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 1

config wifi-iface

option device radio1
option network lan
option mode ap
option ssid OpenWrt
option encryption none

root@OpenWrt:/#

But nothing is mesured on my spectrum analyzer(micronix msa338).
I confirmed it's OK after reverting to r24504.
It seems same as trunk.

regards,
zukky

Attachments (0)

Change History (3)

comment:1 in reply to: ↑ description Changed 7 years ago by anonymous

root@OpenWrt:/# iw phy0 info
Wiphy phy0
        Band 1:
                Frequencies:
                        * 2412 MHz [1] (27.0 dBm)
                        * 2417 MHz [2] (27.0 dBm)
                        * 2422 MHz [3] (27.0 dBm)
                        * 2427 MHz [4] (27.0 dBm)
                        * 2432 MHz [5] (27.0 dBm)
                        * 2437 MHz [6] (27.0 dBm)
                        * 2442 MHz [7] (27.0 dBm)
                        * 2447 MHz [8] (27.0 dBm)
                        * 2452 MHz [9] (27.0 dBm)
                        * 2457 MHz [10] (27.0 dBm)
                        * 2462 MHz [11] (27.0 dBm)
                        * 2467 MHz [12] (disabled)
                        * 2472 MHz [13] (disabled)
                        * 2484 MHz [14] (disabled)
                Bitrates (non-HT):
                        * 1.0 Mbps
                        * 2.0 Mbps (short preamble supported)
                        * 5.5 Mbps (short preamble supported)
                        * 11.0 Mbps (short preamble supported)
                        * 6.0 Mbps
                        * 9.0 Mbps
                        * 12.0 Mbps
                        * 18.0 Mbps
                        * 24.0 Mbps
                        * 36.0 Mbps
                        * 48.0 Mbps
                        * 54.0 Mbps
        Band 2:
                Frequencies:
                        * 5180 MHz [36] (17.0 dBm)
                        * 5200 MHz [40] (17.0 dBm)
                        * 5220 MHz [44] (17.0 dBm)
                        * 5240 MHz [48] (17.0 dBm)
                        * 5260 MHz [52] (20.0 dBm) (passive scanning, no IBSS, radar detection)
                        * 5280 MHz [56] (20.0 dBm) (passive scanning, no IBSS, radar detection)
                        * 5300 MHz [60] (20.0 dBm) (passive scanning, no IBSS, radar detection)
                        * 5320 MHz [64] (20.0 dBm) (passive scanning, no IBSS, radar detection)
                        * 5500 MHz [100] (20.0 dBm) (passive scanning, no IBSS, radar detection)
                        * 5520 MHz [104] (20.0 dBm) (passive scanning, no IBSS, radar detection)
                        * 5540 MHz [108] (20.0 dBm) (passive scanning, no IBSS, radar detection)
                        * 5560 MHz [112] (20.0 dBm) (passive scanning, no IBSS, radar detection)
                        * 5580 MHz [116] (20.0 dBm) (passive scanning, no IBSS, radar detection)
                        * 5600 MHz [120] (disabled)
                        * 5620 MHz [124] (disabled)
                        * 5640 MHz [128] (disabled)
                        * 5660 MHz [132] (20.0 dBm) (passive scanning, no IBSS, radar detection)
                        * 5680 MHz [136] (20.0 dBm) (passive scanning, no IBSS, radar detection)
                        * 5700 MHz [140] (20.0 dBm) (passive scanning, no IBSS, radar detection)
                        * 5745 MHz [149] (30.0 dBm)
                        * 5765 MHz [153] (30.0 dBm)
                        * 5785 MHz [157] (30.0 dBm)
                        * 5805 MHz [161] (30.0 dBm)
                        * 5825 MHz [165] (30.0 dBm)
                Bitrates (non-HT):
                        * 6.0 Mbps
                        * 9.0 Mbps
                        * 12.0 Mbps
                        * 18.0 Mbps
                        * 24.0 Mbps
                        * 36.0 Mbps
                        * 48.0 Mbps
                        * 54.0 Mbps
        max # scan SSIDs: 4
        max scan IEs length: 149749760 bytes
        Coverage class: 0 (up to 0m)
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
        Supported commands:
                 * new_interface
                 * set_interface
                 * new_key
                 * new_beacon
                 * new_station
                 * new_mpath
                 * set_mesh_params
                 * set_bss
                 * authenticate
                 * associate
                 * deauthenticate
                 * disassociate
                 * join_ibss
                 * Unknown command (68)
                 * remain_on_channel
                 * set_tx_bitrate_mask
                 * action
                 * Unknown command (67)
                 * set_wiphy_netns
                 * set_channel
                 * Unknown command (66)
                 * connect
                 * disconnect
        Supported TX frame types:
                 * IBSS: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * managed: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * AP: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * AP/VLAN: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * (null): 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * (null): 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
        Supported RX frame types:
                 * IBSS: 0x00d0
                 * managed: 0x0040 0x00d0
                 * AP: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
                 * AP/VLAN: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
                 * (null): 0x0040 0x00d0
                 * (null): 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
root@OpenWrt:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:0B:6B:2C:15:72
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:72 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:21524 (21.0 KiB)  TX bytes:0 (0.0 B)

eth1      Link encap:Ethernet  HWaddr 00:D0:12:13:44:69
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:125 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:26610 (25.9 KiB)  TX bytes:402 (402.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

mon.wlan0 Link encap:UNSPEC  HWaddr 00-0B-6B-2C-15-72-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:53 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3353 (3.2 KiB)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:0B:6B:2C:15:72
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:71 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:23718 (23.1 KiB)

root@OpenWrt:/# cat /etc/config/wireless
config wifi-device  radio0
        option type     mac80211
        option channel  1
        option macaddr  00:0b:6b:2c:15:72 
        option hwmode   11g

        # REMOVE THIS LINE TO ENABLE WIFI:

#       option disabled 1

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption none

config wifi-device  radio1
        option type     mac80211
        option channel  11
        option macaddr  00:15:6d:65:3e:70 
        option hwmode   11g

        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 1

config wifi-iface
        option device   radio1
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption none

root@OpenWrt:/#

comment:2 Changed 7 years ago by zukky@…

After later update of mac80211, It came to work normally.
Please close this ticket.
Thank you to all devs.
zukky

comment:3 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.