Modify

Opened 7 years ago

Last modified 4 years ago

#8537 new defect

[patch] grub message about packages required for 32 bit build on 64bit Fedora/Centos

Reported by: framer99 Owned by: developers
Priority: low Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: grub fedora i686 glibc working-gcc-m32 Cc:

Description

A previous ticket fixed this grub 32 bit build on x86_64 issue.

/ticket/7269.html

I ran into it again on a new machine and the error message the grub Makefile throws up has package names that aren't quite right. There doesn't seem to be a gcc.i686 package on recent Fedora/Centos x86_64 installs

The attached patch reflects the exact package names i had to "yum install" on a fresh Fedora 14 install. This was after installing the stock installer's "Development Tools" and "Development Libs" group package selections.

Attachments (1)

fedora14_x86_64-32bit-grub-build-requires.patch (545 bytes) - added by framer99 7 years ago.
change package names to isntall on fedora/cenots for 32 bit grub build on 64bit OS

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by framer99

change package names to isntall on fedora/cenots for 32 bit grub build on 64bit OS

comment:1 Changed 7 years ago by mike.mikemiller@…

This is also a issue on Fedora 14 for backfire. Should I open up a new ticket? I see this is Kamikaze. I don't think this is the same issue but the error message points to grub. If you want me to open up a new ticket let me know. I'm totally will to do that.

This is the issue at hand. When I do a "make prereq" after installing all of the required packages on a Fedora 14 fresh install x86 64bit install. I get the following output.

Checking 'working-gcc-m32'... failed.

grub: Please install 32 bits development files. (gcc-multilib on Debian/Ubuntu, gcc.i686 and libgcc.i686 on CentOS/Fedora/RHEL)

make[2]: *** [prereq] Error 1
Package prerequisite check failed.
make[1]: *** [tmp/.prereq_packages] Error 1
make: *** [prereq] Error 2

In case I am doing something wrong. This is the svn info output.

I would provide the package details of what's installed etc. When I tried to post all of that. The post was rejected because of spam.

comment:2 Changed 7 years ago by mike.mikemiller@…

I was asked to run the following on my system.

echo 'int main(int argc, char argv) {

return 0; }' | gcc -x c -o $(TMP_DIR)/a.out - -m32 -lc

It ran fine and produced the a.out file. I did a fine and strings and it looks good.

file Output.
/tmp/a.out: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.32, not stripped

Strings Output
/lib/ld-linux.so.2
libc.so.6
_IO_stdin_used
libc_start_main
gmon_start
GLIBC_2.0
PTRh
[_]

comment:3 Changed 7 years ago by mike.mikemiller@…

After filing that update. I did a 'make prereq' and it produced some putout that basically said gcc 32 ok.

I then did a 'make' and it started to do a make world and build out the rest of the tool chain.

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.