Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8535 closed defect (fixed)

Regression: rev 24791 breaks trunk with recent kernels

Reported by: ddxx0n Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Some things seem to be there for a reason:

Changeset 24791: "xtables-addons: remove configure fix, its unclear what it is supposed to fix"

It is now clear to me, and the content of the patch quite clearly indicates it :-p ... the removal of 002-configure_fix.patch breaks trunk with newer kernels (I am using ar71xx w/ Kernel 2.6.36.2).

Attachments (0)

Change History (6)

comment:1 Changed 7 years ago by ddxx0n

looking at the removed patch again, it seems all kernels with a minor version numbers should fail to configure without it ... as I wrote, I tried it with 2.6.36.2

comment:2 Changed 7 years ago by jow

I cannot see any issue here. How does it "break trunk" ?

comment:3 Changed 7 years ago by Elphidium

Im having the same issue.
Host Slackware 13.1 w/ patch 2.5.4
Building for ar71xx

checking command to parse mips-openwrt-linux-uclibc-nm output from mips-openwrt-linux-uclibc-gcc object... ok
checking for sysroot... no
checking for mips-openwrt-linux-mt... no
checking for mt... mt
configure: WARNING: using cross tools not prefixed with host triplet
checking if mt is a manifest tool... no
checking how to run the C preprocessor... mips-openwrt-linux-uclibc-gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if mips-openwrt-linux-uclibc-gcc supports -fno-rtti -fno-exceptions... no
checking for mips-openwrt-linux-uclibc-gcc option to produce PIC... -fPIC -DPIC
checking if mips-openwrt-linux-uclibc-gcc PIC flag -fPIC -DPIC works... yes
checking if mips-openwrt-linux-uclibc-gcc static flag -static works... yes
checking if mips-openwrt-linux-uclibc-gcc supports -c -o file.o... yes
checking if mips-openwrt-linux-uclibc-gcc supports -c -o file.o... (cached) yes
checking whether the mips-openwrt-linux-uclibc-gcc linker (mips-openwrt-linux-uclibc-ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking linux/netfilter/x_tables.h usability... yes
checking linux/netfilter/x_tables.h presence... yes
checking for linux/netfilter/x_tables.h... yes
checking pkg-config is at least version 0.9.0... yes
checking for libxtables... yes
checking Xtables module directory... /usr/lib/iptables
checking kernel version that we will build against... make[6]: *** [silentoldconfig] Error 1
make[5]: *** [silentoldconfig] Error 2
./configure: line 11618:
*
*
* General setup
*
Prompt for development and/or incomplete code/drivers (EXPERIMENTAL) [Y/n/?] y
Cross+0: syntax error: operand expected (error token is "*
*
* General setup
*
Prompt for development and/or incomplete code/drivers (EXPERIMENTAL) [Y/n/?] y
Cross+0")
make[3]: *** [/home/elphidium/rspro/trunk/build_dir/linux-ar71xx_generic/xtables-addons-1.31/.configured_] Error 1
make[3]: Leaving directory `/home/elphidium/rspro/trunk/feeds/packages/net/xtables-addons'
make[2]: *** [package/feeds/packages/xtables-addons/compile] Error 2
make[2]: Leaving directory `/home/elphidium/rspro/trunk'
make[1]: *** [/home/elphidium/rspro/trunk/staging_dir/target-mips_r2_uClibc-0.9.31/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/elphidium/rspro/trunk'
make: *** [world] Error 2
elphidium@slackware:~/rspro/trunk$

comment:4 Changed 7 years ago by bjorn

I had the same issue as the above poster. The Makefile is running "make kernelrelease" on the kernel source to get the version which triggers a "make silentoldconfig", which when you actually run it on the kernel source causes a prompt about kernel compression mode to appear, so I assume that's what's breaking the build.

My fix was to place the following patch in trunk/feeds/packages/net/xtables-addons/patches/002-configure.patch

diff -Naurw a/configure.ac b/configure.ac
--- a/configure.ac      2010-12-25 00:20:41.000000000 +0000
+++ b/configure.ac      2010-12-25 01:02:47.000000000 +0000
@@ -49,7 +49,7 @@
        echo "WARNING: This distribution's shipped kernel is not supported.";
 fi;
 AC_MSG_CHECKING([kernel version that we will build against])
-krel="$(make -sC ${kbuilddir} kernelrelease)";
+krel="$(cat ${kbuilddir}/include/config/kernel.release)"
 krel="${krel%%-*}";
 kmajor="${krel%%.*}";
 krel="${krel#*.}";

No idea if that's good practice or not. My knowledge of openwrt is somewhat sparse. But it builds and runs fine here.

comment:5 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

I believe the issue is fixed by r24920, if not please reopen.

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.