Modify

Opened 7 years ago

Closed 6 years ago

#8525 closed defect (fixed)

Kernel patches 97x compatibility break

Reported by: vbelo Owned by: florian
Priority: highest Milestone: Backfire 10.03.1
Component: kernel Version: Backfire 10.03.1 RC4
Keywords: Cc:

Description

Kernel Patches 970 to 972 (florian: backport r22727, r22728, r22770 and r22771) breaks compatibility with 88E6060. Since it's the base of the AR7 platform, this is problematic ...

Backfire 10.03.1-RC1 works because it was compiled before the patch.
When I compile trunk with the patch -> Not working
Without the patch -> Working

My hardware : EVO-WR54ADSL (OvisLink)
Network switch : 88E6060-RCJ
Processor : TNETD7300AGDW

Attachments (2)

func.php (2.8 KB) - added by Slavon 4 years ago.
http://nauseapnd.tumblr.com/
README (1.8 KB) - added by Slavon 4 years ago.
smartmilhealth.com

Download all attachments as: .zip

Change History (15)

comment:1 Changed 7 years ago by Simon Iremonger <wiltslug@…>

I concur with problems above, between 10.3.1-rc2 and 10.3.1-rc3 versions of OpenWRT.
In my case, hardware is Netgear DG834Gv3 with AR7 and Marvell 88E6060 switch.

In my case, the result, is that only the port labelled '4' externally works.
No /proc/switch or swconfig access seems to work, and there seems to be no mention of the switch config in the Kernel-Messages.

Unfortunately I don't actually know how to build OpenWRT and I'm going to be busy at College term for a bit! But I'd very much like to see this regression fixed for 10.3.1, and I'd be happy to test etc. if I knew what to do, e.g. if 'vbelo' can supply a test-build of 10.3.1-rc4 for me.

comment:2 Changed 7 years ago by florian

/proc/switch is only for broadcom devices with adm6996 or roboswitches, swconfig should be able to drive the switch though.

The problem is that either we restore dumb support for 88e6060 or we fix all switch drivers once an for all.

comment:3 Changed 7 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to accepted

comment:4 follow-up: Changed 7 years ago by florian

This should be fixed in trunk with r25675, can you give it a try?

comment:5 Changed 7 years ago by Simon Iremonger

I will be very happy to try, but unfortunately I can't do anything with my AR7s until the weekend of 2011-03-26!

Hopefully I can manage to build it manually with the build config copied from the standard AR7 build, unless there are testing builds being produced somewhere I don't know about?

It would help us testers if we had a clear pointer to the article on downloading, and building a testing branch, including howto copy in the standard build config from a 'normal' release architecture.

comment:6 in reply to: ↑ 4 Changed 7 years ago by Simon Iremonger <wiltslug@…>

Replying to florian:

This should be fixed in trunk with r25675, can you give it a try?

Right, I'm at the right place with the right hardware and I now intend to build rev 25675 and put it on one of my pspboot DG834Gv3's unless you tell me that a later trunk version may now be better etc...

I think I've now got enough information to build it. I have ftp via bootloader to recover with if required, too, and I have two of the v3's anyway!!.

comment:7 Changed 7 years ago by Simon Iremonger <wiltslug@…>

OK, finally got r25675 to build (had to turn-off disable various packages/Makefiles)
Is available here for anybody who wants to help test:-

http://hermes.enyc.org.uk/openwrt-2011-02-23-r25675/

I will test soon!

comment:8 Changed 7 years ago by Simon Iremonger <wiltslug@…>

It works it works it works it works! (on DG834Gv3)
I have my native-ipv6 on DSL working and all 4 ethernet ports working.
[using r25675, compiled as per url above]
Fun with the new IPv6 firewalling, but thats a separate issue.
Also, the serial console doesn't quite work, it no longer garbles, get linux kernel messages and "press any key to use this console" sort of message, but pressing anything appears to return a space-character and not work. (The pspboot bootloader is fine).

comment:9 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:10 Changed 7 years ago by florian

  • Resolution fixed deleted
  • Status changed from closed to reopened

This is not fixed yet.

comment:11 follow-up: Changed 7 years ago by Simon Iremonger

I am finding with OpenWRT 10.3.1-rc5 on a DG834Gv3, that the Marvell switch still is such that only one external port works. (i.e. I agree this is 'not fixed' in practice).
On the plus side, with this 2.6.32.37 kernel, the serial console works properly (two ways!) after the system has booted and no longer resorts to garbage or non-responsive-input.
Should we consider 2.6.37 for some ar7's or something? Maybe that will break all sorts of other things ;-). I will go test trunk now too...
--Simon

comment:12 in reply to: ↑ 11 Changed 7 years ago by anonymous

Briefly, for anybody affected by this, I provide a build below of 10.3.1 (between rc5 and rc6) with the patches 970-972 excluded, which 'works for me'.
http://openwrt.enyc.org.uk/openwrt/backfire-2011-07-30-r27838/
(make sure you read Simon-Notes.txt)

comment:13 Changed 6 years ago by florian

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed with r29241

Changed 4 years ago by Slavon

Changed 4 years ago by Slavon

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.