Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8494 closed defect (invalid)

utils/usbutils does not configure/compile

Reported by: floppe@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

checking pkg-config is at least version 0.9.0... yes
checking for LIBUSB... configure: error: Package requirements (libusb-1.0 >= 1.0.0) were not met:

No package 'libusb-1.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBUSB_CFLAGS
and LIBUSB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Attachments (0)

Change History (5)

comment:1 Changed 7 years ago by hauke

  • Resolution set to worksforme
  • Status changed from new to closed

I am unable to reproduce this problem. If the problem still exist please reopen the ticket.

comment:2 Changed 7 years ago by Nenad Opsenica <nenad@…>

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Build od latest backfire still fails:

checking byteswap.h presence... yes
checking for byteswap.h... yes
checking for inflateEnd in -lz... yes
checking pkg-config is at least version 0.9.0... yes
checking for LIBUSB... no
configure: error: Package requirements (libusb-1.0 >= 1.0.0) were not met:

No package 'libusb-1.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBUSB_CFLAGS
and LIBUSB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

comment:3 Changed 7 years ago by Nenad Opsenica <nenad@…>

My mistake.
I didn't install libusb-1.0 from feeds...

./scripts/feeds install  libusb-1.0

was sufficient.

comment:4 Changed 7 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.