Modify

Opened 7 years ago

Closed 3 years ago

#8459 closed defect (moved_to_github)

mjpg-streamer r136-1 broken out of box

Reported by: oss@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: mjpg-streamer webcam streaming UVC Cc:

Description

Looks like the www-folder got removed. On a fresh trunk build, fresh install, I get this error when trying to access mjpg-streamer's HTTP interface:

501: Not Implemented!
no www-folder configured

I have a Logitech UVC fully compatible/supported webcam that I've tested in Ubuntu to work. Willing to help test if you don't =)

Attachments (0)

Change History (5)

comment:1 Changed 7 years ago by anonymous

There needs to be an option added to /etc/config/mjpg-streamer as well to specify the www directory:

Example working command with the /www/webcam_www directory populated with the source from: http://mjpg-streamer.svn.sourceforge.net/viewvc/mjpg-streamer/mjpg-streamer/www/

mjpg_streamer --input "input_uvc.so --device /dev/video0 --fps 15 --resolution 1280x7
20" --output "output_http.so -w /www/webcam_www --port 8090"

Note the "-w /www/webcam_www" part of the output_http.so arguments.

comment:2 Changed 7 years ago by swalker

Dupe of #6499.

Its patch probably needs to be updated to trunk again.

comment:3 Changed 4 years ago by anonymous

I have found you need to set the permissions right:
i have made a new directory: /usr/local/www
sudo chmod 755 /usr/local/www
sudo chmod 644 /usr/local/www/*

mjpg_streamer -i "input_uvc.so -d /dev/video0" -o "output_http.so -p 8080 -w /usr/local/www"

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:5 Changed 3 years ago by jogo

  • Resolution set to moved_to_github
  • Status changed from new to closed

mjpeg-streamer has been moved to https://www.github.com/openwrt/packages. If this is still an issue, please open a ticket there.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.