Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8450 closed defect (fixed)

Package/kernel compiling is still error

Reported by: anonymous Owned by: hauke
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description (last modified by hauke)

I choose Atheros AP96 platform. I do "make distclean" before "make",
It still compiles fail in latest version. message is the same as before:

touch /home/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.31/root-ar71xx/stamp/.hotplug2_installed
make[3]: Leaving directory `/home/openwrt/trunk/package/hotplug2'
make[3]: Entering directory `/home/openwrt/trunk/package/kernel'
mkdir -p /home/openwrt/trunk/dl
make[3]: execvp: /usr/bin/env: Argument list too long
make[3]: *** [/home/openwrt/trunk/dl/zd1201-0.14-fw.tar.gz] Error 127
make[3]: Leaving directory `/home/openwrt/trunk/package/kernel'
make[2]: *** [package/kernel/compile] Error 2
make[2]: Leaving directory `/home/openwrt/trunk'
make[1]: *** [/home/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.31/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/openwrt/trunk'
make: *** [world] Error 2

But if I download package\kernel\modules version r24160, it compiles ok. It seems the latest mk file problem. Please check again.

Attachments (0)

Change History (13)

comment:1 Changed 7 years ago by hauke

  • Description modified (diff)

comment:2 Changed 7 years ago by hauke

Does this problem still exist?

comment:3 Changed 7 years ago by Brian Capouch <brianc@…>

I am getting this exact same problem building for brcm47xx host system is Slackware 11. I originally thought it was the addition of the zd1201 target in wireless.mk (r24443), because I could build the one ahead of it but 24444 broke. There is a funky link in that patch, the one implementing the Download target.

However, I just tried to build 24878, but after downloading I reverted the zd1201 patch in 24443, but it still breaks the same way:

make[3]: Leaving directory `/usr/src/brianc/trunk/package/iproute2'
make[3]: Entering directory `/usr/src/brianc/trunk/package/kernel'
make[3]: execvp: /usr/bin/env: Argument list too long
make[3]: * /usr/src/brianc/trunk/build_dir/linux-brcm47xx/packages/.prepared_14e42541393bb5536b32eba0a609eb1c_check Error 127
make[3]: Leaving directory `/usr/src/brianc/trunk/package/kernel'
make[2]:
* [package/kernel/compile] Error 2
make[2]: Leaving directory `/usr/src/brianc/trunk'
make[1]: * /usr/src/brianc/trunk/staging_dir/target-mipsel_uClibc-0.9.31/stamp/.package_compile Error 2
make[1]: Leaving directory `/usr/src/brianc/trunk'
make:
* [world] Error 2

comment:4 follow-up: Changed 7 years ago by Brian Capouch <brianc@…>

Sorry about the formatting. How do I tell this editor to leave it alone?

comment:5 Changed 7 years ago by Brian Capouch <brianc@…>

Still broken and won't compile with the same error at r25008.

comment:6 in reply to: ↑ 4 Changed 7 years ago by hauke

  • Owner changed from developers to hauke
  • Status changed from new to assigned

Replying to Brian Capouch <brianc@…>:

Sorry about the formatting. How do I tell this editor to leave it alone?

{{{
your code
}}}

See: WikiFormatting#PreformattedText

comment:7 follow-up: Changed 7 years ago by hauke

I am unable to reproduce this issue. Probably it has to do with your Linux distribution your are using.

What Linux distribution are your using?

Please search the revision that braked build, "make download V=99" should be enough to trigger this issue.

comment:8 in reply to: ↑ 7 Changed 7 years ago by anonymous

Replying to hauke:

I am unable to reproduce this issue. Probably it has to do with your Linux distribution your are using.

What Linux distribution are your using?

Please search the revision that braked build, "make download V=99" should be enough to trigger this issue.

I am using Fedora 5(kernel 2.6.20). Even I do "make downlaod V=99", it still can't fix the error.

comment:9 Changed 7 years ago by Brian Capouch <brianc@…>

The last revision I have that builds cleanly is 24442, but I can build 24443 if I remove the code that was added in 24442. But I can't build anything past that.

I assume it's a distribution issue, but it is so strange the way it is behaving. I've been building openWRT for a very long time, but I've never seen anything like this before.

I'm running Slackware 11.0.0 on my development machine. I'm going to try it this week on a machine with a newer version of Slackware and see what happens.

comment:10 Changed 7 years ago by Brian Capouch <brianc@…>

hauke you are correct this problem is distribution-dependent. I moved over to a new development machine this week and the build went perfectly.

From my perspective, then, it's OK to close this ticket. I'm back on track, and thanks for your attentions.

comment:11 Changed 7 years ago by Thomas (thomas.langer@…

The following change fixes this problem on a RHEL4
As most of out machines still run RHEL4, I hope this will be applied.

diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -27,8 +27,10 @@ IPKG_BUILD:= \
 IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/opkg

 define BuildIPKGVariable
+ifdef Package/$(1)/$(2)
   $(call shexport,Package/$(1)/$(2))
   $(1)_COMMANDS += $(SH_FUNC) var2file "$(call shvar,Package/$(1)/$(2))" $(2);
+endif
 endef

 PARENL :=(

comment:12 Changed 7 years ago by nbd

  • Resolution set to fixed
  • Status changed from assigned to closed

patch from the last comment added in r26431

comment:13 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.