Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8448 closed defect (fixed)

Transmission fails to compile

Reported by: Steve <ccdoggy2@…> Owned by: jow
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

This is the output from 'make V=99' after running 'svn update' and './scripts/feeds update' for a AR71XX router (wndr3700).

need anything more just ask.

checking sys/inotify.h usability... yes
checking sys/inotify.h presence... yes
checking for sys/inotify.h... yes
checking for inotify_init... yes
checking sys/event.h usability... no
checking sys/event.h presence... no
checking for sys/event.h... no
checking xfs/xfs.h usability... no
checking xfs/xfs.h presence... no
checking for xfs/xfs.h... no
checking how to copy va_list... va_copy
checking for clock_gettime in -lrt... yes
configure: Using user-specified LIBEVENT_LIBS and LIBEVENT_CFLAGS
checking for GTK... no
./configure: line 18474: syntax error near unexpected token `0.35.0,no-xml'
./configure: line 18474: `    IT_PROG_INTLTOOL(0.35.0,no-xml)'
make[3]: *** [/home/steve/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.31/transmission-2.13/.configured_] Error 2
make[3]: Leaving directory `/home/steve/openwrt/trunk/feeds/packages/net/transmission'
make[2]: *** [package/feeds/packages/transmission/compile] Error 2
make[2]: Leaving directory `/home/steve/openwrt/trunk'
make[1]: *** [/home/steve/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.31/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/steve/openwrt/trunk'
make: *** [world] Error 2

Attachments (0)

Change History (11)

comment:1 Changed 7 years ago by anonymous

make dirclean
update and try again

comment:2 Changed 7 years ago by buildster

A fix is listed in #8400.

comment:3 Changed 7 years ago by jow

  • Owner changed from developers to jow
  • Status changed from new to accepted

comment:4 follow-up: Changed 7 years ago by jow

I need more complete output. Transmission ships the missing macros in m4/glib-gettext.m4 so I don't understand the error above. I also can't reproduce it locall here.

Please attach a full make package/transmission/{clean,compile} V=99 log here.

comment:5 in reply to: ↑ 4 Changed 7 years ago by buildster

Replying to jow:

... Transmission ships the missing macros in m4/glib-gettext.m4

In this case, should PKG_FIXUP:=libtool no-autoreconf be the right fix/workaround for Transmission? See #8400.

comment:6 Changed 7 years ago by Steve <ccdoggy2@…>

Here is the output of doing a 'make dirclean', 'svn update', then 'make package/transmission/{clean,compile} V=99'

http://pastebin.ca/2018641

comment:7 Changed 7 years ago by jow

Well you're supposed to build at least the toolchain before jumping into direct package make targets.

comment:8 Changed 7 years ago by Steve <ccdoggy2@…>

Ok, sorry for the delay. Something else was refusing to compile but got it working. This is all from a fresh svn setup with using an existing .config that i made a few days ago.

I did a make on everything because i was unsure how to just compile the toolchain. It failed, then I did 'make package/transmission/{clean,compile} V=99' and here was the output.

http://pastebin.ca/2019908

comment:9 Changed 7 years ago by Steve <ccdoggy2@…>

It appears to be fixed. no clue what did it, but something in the past 4 days fixed it.

Thanks.

*FIXED*

comment:10 Changed 7 years ago by juhosg

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:11 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.