Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8445 closed defect (duplicate)

Can't compile curl

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

..
..
..
checking for sys/types.h... (cached) yes
checking for sys/socket.h... (cached) no
checking for curl_socklen_t data type... unknown
configure: error: cannot find data type for curl_socklen_t.
make[3]: * DATA/TEST/trunk/build_dir/target-mips_r2_uClibc-0.9.31/curl-7.21.2/.configured_ Error 1
make[3]: Leaving directory `/DATA/TEST/trunk/feeds/packages/libs/curl'
make[2]:
* [package/feeds/packages/curl/compile] Error 2
make[2]: Leaving directory `/DATA/TEST/trunk'
make[1]: * DATA/TEST/trunk/staging_dir/target-mips_r2_uClibc-0.9.31/stamp/.package_compile Error 2
make[1]: Leaving directory `/DATA/TEST/trunk'
make:
* [world] Error 2

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by anonymous

platform ixp4xx,same problem

configure: WARNING: This libcurl built is probably not ABI compatible with previous
configure: WARNING: builds! You MUST read lib/README.curl_off_t to figure it out.
checking for long long... no
checking for ssize_t... no
checking for bool... no
checking for windows.h... (cached) no
checking for winsock2.h... (cached) no
checking for ws2tcpip.h... (cached) no
checking for sys/types.h... (cached) yes
checking for sys/socket.h... (cached) no
checking for curl_socklen_t data type... unknown
configure: error: cannot find data type for curl_socklen_t.
make[3]: *** [/openwrt/10.03/build_dir/target-armeb_v5te_uClibc-0.9.30.1_eabi/curl-7.21.2/.configured_] Error 1
make[3]: Leaving directory `/openwrt/10.03/feeds/packages/libs/curl'
make[2]: *** [package/feeds/packages/curl/compile] Error 2
make[2]: Leaving directory `/openwrt/10.03'
make[1]: *** [/openwrt/10.03/staging_dir/target-armeb_v5te_uClibc-0.9.30.1_eabi/stamp/.package_compile] Error 2
make[1]: Leaving directory `/openwrt/10.03'
make: *** [world] Error 2

comment:2 Changed 7 years ago by marcus.osdoba@…

Duplicate of : #8380
Maybe be "closed" here.

comment:3 Changed 7 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed

see #8380

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.