Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8441 closed defect (duplicate)

Trunk build fails compiling flac

Reported by: Steve <ccdoggy2@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Here is the output from make V=99.

need anything more just let me know.

Making all in flac
make[7]: Entering directory `/home/steve/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.31/flac-1.2.1/src/flac'
/bin/bash ../../libtool --tag=CC   --mode=link mips-openwrt-linux-uclibc-gcc  -O3 -funroll-loops -finline-functions -Wall -W -Winline -Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time -fhonour-copts -msoft-float -fpic   -L/home/steve/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.31/usr/lib -L/home/steve/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.31/lib -L/home/steve/openwrt/trunk/staging_dir/toolchain-mips_r2_gcc-4.3.3+cs_uClibc-0.9.31/usr/lib -L/home/steve/openwrt/trunk/staging_dir/toolchain-mips_r2_gcc-4.3.3+cs_uClibc-0.9.31/lib  -o flac analyze.o decode.o encode.o foreign_metadata.o main.o local_string_utils.o utils.o vorbiscomment.o ../../src/share/grabbag/libgrabbag.la ../../src/share/getopt/libgetopt.a ../../src/share/replaygain_analysis/libreplaygain_analysis.la ../../src/share/replaygain_synthesis/libreplaygain_synthesis.la ../../src/share/utf8/libutf8.la ../../src/libFLAC/libFLAC.la @LIBICONV@ -lm 
libtool: link: mips-openwrt-linux-uclibc-gcc -O3 -funroll-loops -finline-functions -Wall -W -Winline -Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time -fhonour-copts -msoft-float -fpic -o .libs/flac analyze.o decode.o encode.o foreign_metadata.o main.o local_string_utils.o utils.o vorbiscomment.o @LIBICONV@  -L/home/steve/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.31/usr/lib -L/home/steve/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.31/lib -L/home/steve/openwrt/trunk/staging_dir/toolchain-mips_r2_gcc-4.3.3+cs_uClibc-0.9.31/usr/lib -L/home/steve/openwrt/trunk/staging_dir/toolchain-mips_r2_gcc-4.3.3+cs_uClibc-0.9.31/lib ../../src/share/grabbag/.libs/libgrabbag.a ../../src/share/getopt/libgetopt.a ../../src/share/replaygain_analysis/.libs/libreplaygain_analysis.a ../../src/share/replaygain_synthesis/.libs/libreplaygain_synthesis.a ../../src/share/utf8/.libs/libutf8.a ../../src/libFLAC/.libs/libFLAC.so -lm
mips-openwrt-linux-uclibc-gcc: @LIBICONV@: No such file or directory
make[7]: *** [flac] Error 1
make[7]: Leaving directory `/home/steve/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.31/flac-1.2.1/src/flac'
make[6]: *** [all-recursive] Error 1
make[6]: Leaving directory `/home/steve/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.31/flac-1.2.1/src'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/home/steve/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.31/flac-1.2.1'
make[4]: *** [all] Error 2
make[4]: Leaving directory `/home/steve/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.31/flac-1.2.1'
make[3]: *** [/home/steve/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.31/flac-1.2.1/.built] Error 2
make[3]: Leaving directory `/home/steve/openwrt/trunk/feeds/packages/libs/flac'
make[2]: *** [package/feeds/packages/flac/compile] Error 2
make[2]: Leaving directory `/home/steve/openwrt/trunk'
make[1]: *** [/home/steve/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.31/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/steve/openwrt/trunk'
make: *** [world] Error 2

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by arokh <trondah@…>

Duplicate of 8422.

Fix:

PKG_BUILD_DEPENDS:=libintl

comment:2 Changed 7 years ago by florian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8422

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.