Modify

Opened 7 years ago

Closed 7 years ago

#8382 closed defect (fixed)

rtorrent doesn't compile because of xmlrpc-c

Reported by: Prizoff Owned by: jow
Priority: high Milestone:
Component: packages Version: Trunk
Keywords: rtoorrent xmlrpc-c libtorrent libsigc++ Cc:

Description

checking for XMLRPC-C... failed
configure: error: Could not compile XMLRPC-C test.
make[3]: *** [/media/tempfs/trunk/build_dir/target-mipsel_uClibc-0.9.31/rtorrent-0.8.6_r1189/.configured_] Error 1
make[3]: Leaving directory `/media/tempfs/trunk/feeds/packages/net/rtorrent'
make[2]: *** [package/feeds/packages/rtorrent/compile] Error 2
make[2]: Leaving directory `/media/tempfs/trunk'
make[1]: *** [/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/stamp/.package_compile] Error 2
make[1]: Leaving directory `/media/tempfs/trunk'
make: *** [world] Error 2

It seems that problem is in old versions of xmlrpc-c, libtorrent, libsigc++ and rtorrent (tickets #8327, #8275, #8276, #8277, #8278). Beesides, thereis a bug in rtorrent (BackFire 10.03.1 RC-4) (rtorrent does not survive RPC call (ticket #7451) )

Attachments (3)

config.log (36.7 KB) - added by Pri 7 years ago.
packages.patch (6.1 KB) - added by Prizoff 7 years ago.
updates versions to rtorrent-0.8.7_1189, libtorrent-0.12.7_1189, libsigc++-2.2.8, xmlrpc-c-1.24.4_2055
100-libsdeps.patch (443 bytes) - added by kaml 7 years ago.

Download all attachments as: .zip

Change History (11)

comment:2 Changed 7 years ago by Prizoff

So, I downloaded openwrt from trunk #r24355, downgraded then packeges libtorrent, xmlrpc, libsigc++, rtorrent to #r24035 (due ticket #8327) (for applying patches in tickets #8275, #8276, #8277, #8278 thats update version of corresponding packages), applyed the patches.

In attache (configure.log) is more detailed description of error during configure package rtorrent. In shortcut, it is:

configure:16510: mipsel-openwrt-linux-uclibc-g++ -o conftest -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -msoft-float  -DNDEBUG -I/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr//include/sigc++-2.0 -I/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr//lib/sigc++-2.0/include   -I/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr//include   -I/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr//include   -I/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr/include  -I/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr/include -I/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/include -I/media/tempfs/trunk/staging_dir/toolchain-mipsel_gcc-4.3.3+cs_uClibc-0.9.31/usr/include -I/media/tempfs/trunk/staging_dir/toolchain-mipsel_gcc-4.3.3+cs_uClibc-0.9.31/include  -L/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr/lib -L/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/lib -L/media/tempfs/trunk/staging_dir/toolchain-mipsel_gcc-4.3.3+cs_uClibc-0.9.31/usr/lib -L/media/tempfs/trunk/staging_dir/toolchain-mipsel_gcc-4.3.3+cs_uClibc-0.9.31/lib  conftest.cpp -lncurses  -L/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr//lib -lsigc-2.0   -L/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr//lib -lcurl   -L/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr//lib -ltorrent   -L/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr/lib   -lxmlrpc_server -lxmlrpc -lxmlrpc_util -L/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr/lib -lxml2 -lz -lm  >&5
/media/tempfs/trunk/staging_dir/toolchain-mipsel_gcc-4.3.3+cs_uClibc-0.9.31/lib/gcc/mipsel-openwrt-linux-uclibc/4.3.3/../../../../mipsel-openwrt-linux-uclibc/bin/ld: warning: libcrypto.so.0.9.8, needed by /media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr/lib/libcurl.so, not found (try using -rpath or -rpath-link)
/media/tempfs/trunk/staging_dir/toolchain-mipsel_gcc-4.3.3+cs_uClibc-0.9.31/lib/gcc/mipsel-openwrt-linux-uclibc/4.3.3/../../../../mipsel-openwrt-linux-uclibc/bin/ld: warning: libssl.so.0.9.8, needed by /media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr/lib/libcurl.so, not found (try using -rpath or -rpath-link)
/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr/lib/libcurl.so: undefined reference to `SSL_connect'
/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr/lib/libcurl.so: undefined reference to `X509_check_issued'
<skipped other SSL*functions>

Changed 7 years ago by Pri

comment:3 Changed 7 years ago by anonymous

It seems to me that double slash is the reason of error...:

pkg_cv_libcurl_CFLAGS='-I/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr//include  '
pkg_cv_libcurl_LIBS='-L/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr//lib -lcurl  '
pkg_cv_libtorrent_CFLAGS='-I/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr//include  '
pkg_cv_libtorrent_LIBS='-L/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr//lib -ltorrent  '
pkg_cv_sigc_CFLAGS='-I/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr//include/sigc++-2.0 -I/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr//lib/sigc++-2.0/include  '
pkg_cv_sigc_LIBS='-L/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr//lib -lsigc-2.0  '

comment:4 Changed 7 years ago by Prizoff

So, finally.
The problem is in absence of -lssl -lcrypto in $LIBS in script configure after "checking for libcurl... yes". The contents of $LIBS in that moment is:

LIBS=-lncurses  -L/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr/lib -lsigc-2.0   -L/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr/lib -lcurl   -L/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr/lib -ltorrent   -L/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr/lib   -lxmlrpc_server -lxmlrpc -lxmlrpc_util -L/media/tempfs/trunk/staging_dir/target-mipsel_uClibc-0.9.31/usr/lib -lxml2 -lz -lm

Why is this happening I can't understand :(

comment:5 Changed 7 years ago by Prizoff

Here is a cumulative patch to svn revision 24436 for compile rtorrent/libtorrent (it updates versions to rtorrent-0.8.7_1189, libtorrent-0.12.7_1189, libsigc++-2.2.8, xmlrpc-c-1.24.4_2055) (0.8.7/0.12.7). But this doesn't solves primary problem. Rtorrent does continue fail on xmlrpc-call :(

Can somebody help to solve this issue?

Changed 7 years ago by Prizoff

updates versions to rtorrent-0.8.7_1189, libtorrent-0.12.7_1189, libsigc++-2.2.8, xmlrpc-c-1.24.4_2055

comment:6 Changed 7 years ago by kaml

Here is a patch I made for curl. Just copy it to curl/patches directory.

Changed 7 years ago by kaml

comment:7 Changed 7 years ago by jow

  • Owner changed from developers to jow
  • Status changed from new to accepted

comment:8 Changed 7 years ago by anonymous

Somebody put these changes in a next rev. please.

comment:9 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from accepted to closed

Should be fixed by now

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.