Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8371 closed defect (worksforme)

libupnp fails build in current trunk (collect2...)

Reported by: marcus.osdoba@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

I get the following error compiling the current trunk (r24287)

..
~openwrt-dev/trunk/staging_dir/toolchain-arm_v5te_gcc-4.4.5_uClibc-0.9.31_eabi/lib/gcc/arm-openwrt-linux-uclibcgnueabi/4.4.5/../../../../arm-openwrt-linux-uclibcgnueabi/bin/ld: skipping incompatible /usr/lib/libpthread.so when searching for -lpthread
/usr/lib/libpthread.a: could not read symbols: File format not recognized
collect2: ld returned 1 exit status
libtool: install: error: relink `libupnp.la' with the above command before installing it
..

It is similar to other errors after libtool update like
#8342 #8262 #8361 and maybe others

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by acoul

  • Resolution set to worksforme
  • Status changed from new to closed

try a fresh trunk checkout and always issue a "make distclean".

comment:2 Changed 7 years ago by marcus.osdoba@…

Confirmed. At least since r24564 it compiles through again. "make dirclean" is sufficient.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.