Modify

Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#8354 closed defect (duplicate)

Not build luci for eglibc

Reported by: anonymous Owned by:
Priority: normal Milestone: Barrier Breaker 14.07
Component: luci Version: Trunk
Keywords: Cc:

Description

mipsel-openwrt-linux-gnu-gcc -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -msoft-float -I/home/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.12/usr/include/libnl-tiny -I/home/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.12/usr/include -std=gnu99 -fstrict-aliasing -DUSE_NL80211  -fpic -c -o iwinfo_utils.o iwinfo_utils.c
In file included from /home/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.12/usr/include/libnl-tiny/netlink/netlink.h:30,
                 from iwinfo_nl80211.h:29,
                 from iwinfo.h:32,
                 from iwinfo_utils.h:25,
                 from iwinfo_utils.c:23:
/home/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.12/usr/include/libnl-tiny/netlink/handlers.h:133: warning: 'struct ucred' declared inside parameter list
/home/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.12/usr/include/libnl-tiny/netlink/handlers.h:207: warning: 'struct ucred' declared inside parameter list
/home/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.12/usr/include/libnl-tiny/netlink/handlers.h: In function 'nl_cb_overwrite_recv':
/home/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.12/usr/include/libnl-tiny/netlink/handlers.h:209: warning: assignment from incompatible pointer type
In file included from iwinfo_nl80211.h:29,
                 from iwinfo.h:32,
                 from iwinfo_utils.h:25,
                 from iwinfo_utils.c:23:
/home/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.12/usr/include/libnl-tiny/netlink/netlink.h: At top level:
/home/sysadmin/wl500/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.12/usr/include/libnl-tiny/netlink/netlink.h:57: warning: 'struct ucred' declared inside parameter list
In file included from /home/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.12/usr/include/libnl-tiny/netlink/genl/genl.h:16,
                 from iwinfo_nl80211.h:30,
                 from iwinfo.h:32,
                 from iwinfo_utils.h:25,
                 from iwinfo_utils.c:23:
/home/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.12/usr/include/libnl-tiny/netlink/msg.h:52: error: field 'nm_creds' has incomplete type
/home/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.12/usr/include/libnl-tiny/netlink/msg.h: In function 'nlmsg_set_creds':
/home/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.12/usr/include/libnl-tiny/netlink/msg.h:207: error: dereferencing pointer to incomplete type
make[4]: *** [iwinfo_utils.o] Error 1

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by swalker

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #8306.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.