Modify

Opened 7 years ago

Closed 7 years ago

#8353 closed defect (duplicate)

libxtables.a installation issue

Reported by: Alexey Tarasov Owned by: developers
Priority: low Milestone: Backfire 10.03.1
Component: packages Version: Trunk
Keywords: iptables libxtables.a Cc:

Description

Updated sources to latest, started compilation (for x86 target), got problem with libxtables.a copying.
Like this one:

cp -fpR /home/taleks/wrt/wrtsource/trunk/build_dir/linux-x86_generic/iptables-1.4.9.1/ipkg-install/usr/lib/libip*tc.{a,so*} /home/taleks/wrt/wrtsource/trunk/tmp/stage-iptables/usr/lib/
cp: cannot stat `/home/taleks/wrt/wrtsource/trunk/build_dir/linux-x86_generic/iptables-1.4.9.1/ipkg-install/usr/lib/libip*tc.a': No such file or directory

Looked a bit to it and attached is quick and dirty solution.
Seems libraries naming convention (.a -> .la) changed, which is not yet reflected in Makefile.

Index: package/iptables/Makefile
===================================================================
--- package/iptables/Makefile	(revision 24240)
+++ package/iptables/Makefile	(working copy)
@@ -325,9 +325,12 @@
 
 	$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
 	$(INSTALL_DIR) $(1)/usr/lib
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libxtables.{a,so*} $(1)/usr/lib/
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libip*tc.{a,so*} $(1)/usr/lib/
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libipq.{a,so*} $(1)/usr/lib/
+#	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libxtables.{a,so*} $(1)/usr/lib/
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libxtables.{la,so*} $(1)/usr/lib/
+#	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libip*tc.{a,so*} $(1)/usr/lib/
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libip*tc.{la,so*} $(1)/usr/lib/
+#	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libipq.{a,so*} $(1)/usr/lib/
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libipq.{la,so*} $(1)/usr/lib/
 	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
 	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/xtables.pc $(1)/usr/lib/pkgconfig/
 	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libiptc.pc $(1)/usr/lib/pkgconfig/

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by mirko

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #8350

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.