Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8342 closed defect (fixed)

mysql 5.1.53 compile error

Reported by: anonymous Owned by: hauke
Priority: normal Milestone: Backfire 10.03.1
Component: packages Version: Backfire 10.03.1 RC4
Keywords: mysql 5.1.53 compile error Cc:

Description (last modified by hauke)

Compile backfire from svn target is x86
If I only revert mysql to rev 24052 (mysql 5.0.18) it do compile without error.

/bin/bash ../libtool --preserve-dup-deps --tag=CC   --mode=link gcc   -static -L/mnt/systemdisk/openwrt/Aopen-openwrt-backfire/staging_dir/target-i386_uClibc-0.9.30.1/usr/lib -L/mnt/systemdisk/openwrt/Aopen-openwrt-backfire/staging_dir/target-i386_uClibc-0.9.30.1/lib -L/mnt/systemdisk/openwrt/Aopen-openwrt-backfire/staging_dir/toolchain-i386_gcc-4.1.2_uClibc-0.9.30.1/usr/lib -L/mnt/systemdisk/openwrt/Aopen-openwrt-backfire/staging_dir/toolchain-i386_gcc-4.1.2_uClibc-0.9.30.1/lib  -rdynamic  -o conf_to_src conf_to_src.o
gcc -rdynamic -o conf_to_src conf_to_src.o  -L/mnt/systemdisk/openwrt/Aopen-openwrt-backfire/staging_dir/target-i386_uClibc-0.9.30.1/usr/lib -L/mnt/systemdisk/openwrt/Aopen-openwrt-backfire/staging_dir/target-i386_uClibc-0.9.30.1/lib -L/mnt/systemdisk/openwrt/Aopen-openwrt-backfire/staging_dir/toolchain-i386_gcc-4.1.2_uClibc-0.9.30.1/usr/lib -L/mnt/systemdisk/openwrt/Aopen-openwrt-backfire/staging_dir/toolchain-i386_gcc-4.1.2_uClibc-0.9.30.1/lib
/usr/bin/ld: warning: ld-uClibc.so.0, needed by /mnt/systemdisk/openwrt/Aopen-openwrt-backfire/staging_dir/toolchain-i386_gcc-4.1.2_uClibc-0.9.30.1/usr/lib/libc.so, not found (try using -rpath or -rpath-link)
/usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/crt1.o: In function `_start':
(.text+0xc): undefined reference to `__libc_csu_fini'
/usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/crt1.o: In function `_start':
(.text+0x11): undefined reference to `__libc_csu_init'
/usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/crt1.o: In function `_start':
(.text+0x1d): undefined reference to `__libc_start_main'
conf_to_src.o: In function `print_array':
conf_to_src.c:(.text+0x18d): undefined reference to `__ctype_b_loc'
conf_to_src.c:(.text+0x226): undefined reference to `__ctype_b_loc'
conf_to_src.c:(.text+0x349): undefined reference to `__stack_chk_fail'
/mnt/systemdisk/openwrt/Aopen-openwrt-backfire/staging_dir/toolchain-i386_gcc-4.1.2_uClibc-0.9.30.1/usr/lib/libc.so: undefined reference to `_dl_app_init_array'
/mnt/systemdisk/openwrt/Aopen-openwrt-backfire/staging_dir/toolchain-i386_gcc-4.1.2_uClibc-0.9.30.1/usr/lib/libc.so: undefined reference to `_dl_loaded_modules'
/mnt/systemdisk/openwrt/Aopen-openwrt-backfire/staging_dir/toolchain-i386_gcc-4.1.2_uClibc-0.9.30.1/usr/lib/libc.so: undefined reference to `_dl_app_fini_array'
collect2: ld returned 1 exit status
make[4]: *** [conf_to_src] Error 1

Attachments (0)

Change History (8)

comment:1 Changed 7 years ago by hauke

  • Owner changed from developers to hauke
  • Status changed from new to assigned

comment:2 Changed 7 years ago by rossb@…

I experienced something very similar to this with mysql at R25302 where libtool was attempting to link to my system crtl.o as opposed to the cross compile version (path problem).

This went away after I saved .config, did a make distclean, restored .config, make menuconfig, save, make.

May not be a bug.

comment:3 Changed 7 years ago by huey07@…

I'm able to reproduce this issue in both trunk and stable.

comment:4 Changed 7 years ago by anonymous

Same here

comment:5 Changed 7 years ago by hauke

  • Description modified (diff)

comment:6 Changed 7 years ago by hauke

This has two duplicates: #8968 and #9195

comment:7 Changed 7 years ago by hauke

  • Resolution set to fixed
  • Status changed from assigned to closed

Thank you for reporting.

This should be fixed in r26540.

The problem did not occurred on my system because I am using an AMD64 system and this just occurs on i386 systems. Please test the fix and reopen the ticket if it still doe snot build.

comment:8 Changed 7 years ago by Nicolas Le Falher <n.lefalher@…>

Its works, thanks :).

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.