Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8299 closed defect (worksforme)

OpenWrt & DWL-2100AP

Reported by: Silvio Peša <vpritiskovic@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc: nbd, Kaloz

Description

Neither one of generic builds from http://downloads.openwrt.org/backfire/version/atheros
does work for this device.
Kernel hangs.
Tested.
If I download latest trunk svn, compile, flash, kernel hang.

I have a wokaround for DWL-2100AP H/W vA2 (tnx laigor)

If I change in ./target/linux/atheros/Makefile

from LINUX_VERSION:=2.6.32.25
to LINUX_VERSION:=2.6.30.10

compiled, reflashed and it works flawless.

What can be done about that?

Attachments (2)

r24063.txt (5.6 KB) - added by Silvio Peša <vpritiskovic@…> 7 years ago.
bootlog
10.03.1-rc4-r24045.txt (8.3 KB) - added by anonymous 7 years ago.
bootlog

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by Silvio Peša <vpritiskovic@…>

bootlog

comment:1 Changed 7 years ago by anonymous

10.03.1-rc4, r24045 /atheros WORKS!

added bootlog in attachment

Changed 7 years ago by anonymous

bootlog

comment:2 Changed 7 years ago by Silvio Peša <vpritiskovic@…>

Update: DWL-2100 is supported with backfire 10.03.1-rc1 on.
releases 10.03.1-rc2,rc3 and rc4 working normal.

comment:3 Changed 7 years ago by acoul

  • Resolution set to fixed
  • Status changed from new to closed

I am closing this ticket. thank you for testing and reporting.

comment:4 follow-up: Changed 7 years ago by florian

  • Resolution fixed deleted
  • Status changed from closed to reopened

I do not think this device works correctly with trunk, it needs fixing too.

comment:5 Changed 7 years ago by Silvio Peša <vpritiskovic@…>

1) Backfire branch is working with kernel-2.6.30.10 out of the box. Tested 10.03.1-rc1, 10.03.1-rc2, 10.03.1-rc3 and 10.03.1-rc4.

2) Trunk branch with newer kernel than kernel-2.6.30.10 requires uClibc-0.9.32 and gcc-4.5.1 in toolchain when compiling.
Tested with kernels 2.6.32.26, 2.6.36.1 and 2.6.37-rc3. Resulting generic atheros builds (when flashed - openwrt-atheros-vmlinux.lzma + openwrt-atheros-root.squashfs) I can confirm - working normal, I am ready if additional testing is required.

comment:6 in reply to: ↑ 4 Changed 7 years ago by anonymous

Replying to florian:

I do not think this device works correctly with trunk, it needs fixing too.

I have flashed the backfire 10.03 (kernel.lzma+root.squashfs) and kernel does not boot to end:

RedBoot> fis load -l linux
lzma_init: initialize the decoder
lzma_inflate: decompress stream
lzma_inflate; copy decodification code to RAM
Image loaded from 0x80041000-0x802ea200
RedBoot> exec
Now booting linux kernel:
 Base address 0x80080000 Entry 0x80041000
 Cmdline :
Linux version 2.6.30.10 (openwrt@wrt1.marcant.net) (gcc version 4.3.3 (GCC) ) #24 Tue Apr 6 14:59:59 CEST 2010
console [early0] enabled
CPU revision is: 0001800a (MIPS 4Kc)
Determined physical RAM map:
 memory: 01000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00001000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00001000
Built 1 zonelists in Zone order, mobility grouping off.  Total pages: 4064
Kernel command line: console=ttyS0,9600 rootfstype=squashfs,jffs2
Primary instruction cache 16kB, VIPT, 4-way, linesize 16 bytes.
Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 16 bytes
NR_IRQS:128
PID hash table entries: 64 (order: 6, 256 bytes)
console handover: boot [early0] -> real [ttyS0]
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Memory: 13024k/16384k available (2175k kernel code, 3360k reserved, 413k data, 136k init, 0k highmem)
Calibrating delay loop... 179.81 BogoMIPS (lpj=899072)
Mount-cache hash table entries: 512
net_namespace: 1008 bytes
NET: Registered protocol family 16
bio: create slab <bio-0> at 0
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 512 (order: 0, 4096 bytes)
TCP bind hash table entries: 512 (order: -1, 2048 bytes)
TCP: Hash tables configured (established 512 bind 512)
TCP reno registered
NET: Registered protocol family 1
Radio config found at offset 0x10000(0x100)
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  Š 2001-2006 Red Hat, Inc.
msgmni has been set to 25
alg: No test for stdrng (krng)
io scheduler noop registered
io scheduler deadline registered (default)
gpiodev: gpio device registered with major 254
gpiodev: gpio platform device registered with access mask FFFFFFFF
Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
serial8250: ttyS0 at MMIO 0xbc000003 (irq = 37) is a 16550A
eth0: Atheros AR231x: 00:0f:3d:af:eb:05, irq 4
ar231x_eth_mii: probed
eth0: attached PHY driver [Generic PHY] (mii_bus:phy_addr=0:01)
physmap platform flash device: 00800000 at 1e000000
physmap-flash.0: Found 1 x16 devices at 0x0 in 8-bit bank
 Amd/Fujitsu Extended Query Table at 0x0041
number of CFI chips: 1
cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
cmdlinepart partition parsing not available
Searching for RedBoot partition table in physmap-flash.0 at offset 0x3d0000
5 RedBoot partitions found on MTD device physmap-flash.0
Creating 5 MTD partitions on "physmap-flash.0":
0x000000000000-0x000000030000 : "RedBoot"
0x000000100000-0x0000001e0000 : "linux"
0x0000003c0000-0x0000003c1000 : "RedBoot config"
0x0000003d0000-0x0000003e0000 : "FIS directory"
0x0000003e0000-0x000000400000 : "boardconfig"
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
eth0: Configuring MAC for full duplex
Reserved instruction in kernel code[#1]:
Cpu 0
$ 0   : 00000000 1000d000 ffffffff ffffffff
$ 4   : 803a5140 00000000 00000000 666d58d2
$ 8   : 00000000 803a5198 802b3ad8 802b3b14
$12   : ffffffff 00000050 ca62c1d6 ffffffff
$16   : 00000000 803a5140 00000000 802776c8
$20   : 00000000 80361f80 00000000 00000000
$24   : 00000000 8f1bbcdc
$28   : 80360000 80361f70 00000000 800cf6dc
Hi    : 00000057
Lo    : 5c28f60f
epc   : 8008003c 0x8008003c
    Not tainted
ra    : 800cf6dc 0x800cf6dc
Status: 1000d003    KERNEL EXL IE
Cause : 30800028
PrId  : 0001800a (MIPS 4Kc)
Modules linked in:
Process swapper (pid: 1, threadinfo=80360000, task=8035e928, tls=00000000)
Stack : 00000000 00000080 802b0000 00000000 00000000 80092c48 802e8b14 802e8dc0
        802e8dc0 00000000 00000000 00000000 00000000 802c9340 00000000 00000000
        00000000 00000000 80360000 00000000 00000000 8004ec74 1000c003 00000000
        00000000 00000000 00000000 00000000 096c096c 14001405 00000000 00000000
        00000000 00000000 00000000 00000000
Call Trace:[<80092c48>] 0x80092c48
[<802c9340>] 0x802c9340
[<8004ec74>] 0x8004ec74


Code: 30783031  30303030  3030006d <6f646574> 74793000  302c6e2c  382c312c  68770065  74686164
Disabling lock debugging due to kernel taint
Kernel panic - not syncing: Attempted to kill init!

Then I have flashed backfire 10.03.1-rc1 (first that works with this ap out of the box):

RedBoot(tm) bootstrap and debug environment [ROM]
Non-certified release, version v2_0 - built 16:27:48, Jul  1 2007
With changes made by Waldeck Schutzer <waldeck@dm.ufscar.br>


Copyright (C) 2000, 2001, 2002, Red Hat, Inc.

RAM: 0x80000400-0x81000000, 0x80000400-0x807d1ce0 available
FLASH: 0xbfc00000 - 0xbffe0000, 62 blocks of 0x00010000 bytes each.
== Executing boot script in 4.000 seconds - enter ^C to abort
RedBoot> fis load -l linux
lzma_init: initialize the decoder
lzma_inflate: decompress stream
lzma_inflate; copy decodification code to RAM
Image loaded from 0x80041000-0x802ec200
RedBoot> exec
Now booting linux kernel:
 Base address 0x80080000 Entry 0x80041000
 Cmdline :
Linux version 2.6.30.10 (openwrt@ampere) (gcc version 4.3.3 (GCC) ) #1 Tue Aug 10 03:10:17 PDT 2010
console [early0] enabled
CPU revision is: 0001800a (MIPS 4Kc)
Determined physical RAM map:
 memory: 01000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00001000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00001000
Built 1 zonelists in Zone order, mobility grouping off.  Total pages: 4064
Kernel command line: console=ttyS0,9600 rootfstype=squashfs,jffs2
Primary instruction cache 16kB, VIPT, 4-way, linesize 16 bytes.
Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 16 bytes
NR_IRQS:128
PID hash table entries: 64 (order: 6, 256 bytes)
console handover: boot [early0] -> real [ttyS0]
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Memory: 13000k/16384k available (2180k kernel code, 3384k reserved, 417k data, 136k init, 0k highmem)
Calibrating delay loop... 179.81 BogoMIPS (lpj=899072)
Mount-cache hash table entries: 512
net_namespace: 1008 bytes
NET: Registered protocol family 16
bio: create slab <bio-0> at 0
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 512 (order: 0, 4096 bytes)
TCP bind hash table entries: 512 (order: -1, 2048 bytes)
TCP: Hash tables configured (established 512 bind 512)
TCP reno registered
NET: Registered protocol family 1
Radio config found at offset 0x10000(0x100)
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  Š 2001-2006 Red Hat, Inc.
msgmni has been set to 25
alg: No test for stdrng (krng)
io scheduler noop registered
io scheduler deadline registered (default)
gpiodev: gpio device registered with major 254
gpiodev: gpio platform device registered with access mask FFFFFFFF
Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
serial8250: ttyS0 at MMIO 0xbc000003 (irq = 37) is a 16550A
eth0: Atheros AR231x: 00:0f:3d:af:eb:05, irq 4
ar231x_eth_mii: probed
eth0: attached PHY driver [Generic PHY] (mii_bus:phy_addr=0:01)
physmap platform flash device: 00800000 at 1e000000
physmap-flash.0: Found 1 x16 devices at 0x0 in 8-bit bank
 Amd/Fujitsu Extended Query Table at 0x0041
number of CFI chips: 1
cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
cmdlinepart partition parsing not available
Searching for RedBoot partition table in physmap-flash.0 at offset 0x3d0000
6 RedBoot partitions found on MTD device physmap-flash.0
Creating 6 MTD partitions on "physmap-flash.0":
0x000000000000-0x000000030000 : "RedBoot"
0x000000030000-0x000000110000 : "linux"
0x000000110000-0x0000003c0000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=2B0000, len=110000
0x0000002b0000-0x0000003c0000 : "rootfs_data"
0x0000003c0000-0x0000003c1000 : "RedBoot config"
0x0000003d0000-0x0000003e0000 : "FIS directory"
eth0: Configuring MAC for full duplex
0x0000003e0000-0x000000400000 : "boardconfig"
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
Freeing unused kernel memory: 136k freed
Please be patient, while OpenWrt loads ...
- preinit -
Press the [f] key and hit [enter] to enter failsafe mode
- regular preinit -
jffs2 not rmini_fo: using base directory: /
eady yet; using mini_fo: using storage directory: /tmp/root
ramdisk
- init -

Please press Enter to activate this console. device eth0 entered promiscuous mode
br-lan: port 1(eth0) entering forwarding state
PPP generic driver version 2.4.2
ip_tables: (C) 2000-2006 Netfilter Core Team
NET: Registered protocol family 24
nf_conntrack version 0.5.0 (256 buckets, 1024 max)
CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
nf_conntrack.acct=1 kernel paramater, acct=1 nf_conntrack module option or
sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
ath_hal: module license 'Proprietary' taints kernel.
Disabling lock debugging due to kernel taint
ath_hal: 2009-05-08 (AR5212, AR5312, RF5111, RF5112, RF2316, RF2317, REGOPS_FUNC, TX_DESC_SWAP, XR)
ath_ahb: trunk
wlan: trunk
wlan: mac acl policy registered
ath_rate_minstrel: Minstrel automatic rate control algorithm 1.2 (trunk)
ath_rate_minstrel: look around rate set to 10%
ath_rate_minstrel: EWMA rolloff level set to 75%
ath_rate_minstrel: max segment size in the mrr set to 6000 us
Atheros HAL provided by OpenWrt, DD-WRT and MakSat Technologies
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
ath_ahb: wifi0: Atheros 2313 WiSoC: mem=0xb8500000, irq=5
IRQ 5/wifi0: IRQF_DISABLED is not guaranteed on shared IRQs
jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
jffs2_build_filesystem(): unlocking the mtd device... done.
jffs2_build_filesystem(): erasing all blocks after the end marker... done.
mini_fo: using base directory: /
mini_fo: using storage directory: /overlay



BusyBox v1.15.3 (2010-07-11 02:09:20 PDT) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 Backfire (10.03.1-rc1, r22556) --------------------
  * 1/3 shot Kahlua    In a shot glass, layer Kahlua
  * 1/3 shot Bailey's  on the bottom, then Bailey's,
  * 1/3 shot Vodka     then Vodka.
 ---------------------------------------------------
root@OpenWrt:/# lsmod
Module                  Size  Used by    Tainted: P
ath_ahb               320320  0
ath_hal               161248  2 ath_ahb
nf_nat_tftp              448  0
nf_conntrack_tftp       2400  1 nf_nat_tftp
nf_nat_irc               832  0
nf_conntrack_irc        2576  1 nf_nat_irc
nf_nat_ftp              1344  0
nf_conntrack_ftp        4784  1 nf_nat_ftp
ipt_MASQUERADE          1088  1
iptable_nat             2848  1
nf_nat                 11424  5 nf_nat_tftp,nf_nat_irc,nf_nat_ftp,ipt_MASQUERADE,iptable_nat
xt_NOTRACK               624  0
iptable_raw              656  1
xt_state                 800  3
nf_conntrack_ipv4       8272  6 iptable_nat,nf_nat
nf_defrag_ipv4           624  1 nf_conntrack_ipv4
nf_conntrack           40784 12 nf_nat_tftp,nf_conntrack_tftp,nf_nat_irc,nf_conntrack_irc,nf_nat_ftp,nf_conntrack_ftp,ipt_MASQUERADE,iptable_nat,nf_nat,xt_NOTRACK,xt_state,nf_conntrack_ipv4
pppoe                   8912  0
pppox                   1280  1 pppoe
ipt_REJECT              1888  2
xt_TCPMSS               2624  1
ipt_LOG                 4304  0
xt_comment               480  0
xt_multiport            1856  0
xt_mac                   592  0
xt_limit                1232  1
iptable_mangle          1008  0
iptable_filter           784  1
ip_tables               8320  4 iptable_nat,iptable_raw,iptable_mangle,iptable_filter
xt_tcpudp               1792  4
x_tables                9488 13 ipt_MASQUERADE,iptable_nat,xt_NOTRACK,xt_state,ipt_REJECT,xt_TCPMSS,ipt_LOG,xt_comment,xt_multiport,xt_mac,xt_limit,ip_tables,xt_tcpudp
ppp_async               7952  0
ppp_generic            20336  3 pppoe,pppox,ppp_async
slhc                    4720  1 ppp_generic
crc_ccitt                992  1 ppp_async
root@OpenWrt:/#

From my point of view I can tell that kernel (2.6.30.10) and gcc (4.3.3) are same in both builds, don't know about binutils and uClibc versions.

I think it has something to do with OpenWrt development which fixes rc-1 build (and recent backfire rc2,rc3 and rc4) to finally boot/work as it shuold. So, if you could trace back changes regarding atheros platform from 10.03 to 10.03.1-rc1 you would probably find out issue(s) causing the kernel hangs since this is happening again with the trunk builds made with default toolchain. IMHO that's the place to serach sollution for fixing. Correct me if I am wrong, but this felt into my eyes...

I am ready to do any additional testing if required.

comment:7 Changed 7 years ago by acoul

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:8 Changed 7 years ago by gena2x

A4, backfire, working out of box.

I am not using flash in device, just setup bootloader to boot from network.

comment:9 Changed 6 years ago by anonymous

RC5 work out of box too.

comment:10 Changed 4 years ago by jow

  • Cc nbd Kaloz added; nbd Kaloz removed
  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.