Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8281 closed defect (duplicate)

Transmission every piece fails checksum test (possible uclibc problem)

Reported by: Steve <ccdoggy2@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

When transmission is installed or built from trunk every piece of every torrent comes up as failing a checksum and so is trashed. None make any progress towards completion.

https://forum.openwrt.org/viewtopic.php?id=27368

Nov 17 10:47:53 OpenWrt user.err transmission-daemon[4197]: NAME OF FILE HERE Piece 13758, which was just downloaded, failed its checksum test (peer-mgr.c:1468)

Messages exactly like that fill up my log just listing all the different pieces its attempting to download.

Built from trunk and from repository. It has been suggested this is a problem with the new uclibc file. I can give any info if it helps, just need to know what to do.

Attachments (0)

Change History (5)

comment:1 Changed 7 years ago by CsD

I have got the same problem. Transmission from trunk doesn't work on my DIR-825.

Download completes, but files cannot be opened. After re-verifying data, the downloaded ammount deceases to only 1-2%, and start downlaoding again. Of cousre it will be junk again.

If I try to verify some previously correct files, happens the same.

comment:2 Changed 7 years ago by Drag Den

It appears that transmission also does not correctly choose begin and end of file. For example, when you choose only one file, transmission downloads only part of this file, and parts of some other files.

comment:3 Changed 7 years ago by Steve <ccdoggy2@…>

looks like some have been having this problem for a while now though on NSLU2 systems.

Transmission tracker: https://trac.transmissionbt.com/ticket/2858

I know very little about compiling/patches/associated stuff so really have no idea how to implement the attached patch. Though no one really replied about if the patch works or not or really what the patch is fixing exactly.

comment:4 Changed 7 years ago by acoul

  • Resolution set to duplicate
  • Status changed from new to closed

dupe of #8166

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.