Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#8267 closed defect (fixed)

hostapd segfaults

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: hostapd Cc:

Description

I run hostapd in 802.1X mode with radius authentication and I am getting segfault. This was working before recent updates.

Am attaching a strace and the config file i am using.

Program received signal SIGSEGV, Segmentation fault.
0x00417984 in os_strlcpy ()
(gdb) bt
#0 0x00417984 in os_strlcpy ()
#1 0x00426f20 in wpa_driver_wext_set_key ()
#2 0x004260c0 in madwifi_set_key ()
#3 0x00406504 in hostapd_setup_encryption ()
#4 0x00406a08 in hostapd_setup_interface_complete ()
#5 0x004071c0 in hostapd_setup_interface ()
#6 0x00402a18 in hostapd_main ()
#7 0x2ab381b8 in ?? ()

Attachments (2)

hostapd-ath2.conf (393 bytes) - added by anonymous 7 years ago.
strace.out (10.3 KB) - added by anonymous 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by anonymous

Changed 7 years ago by anonymous

comment:1 Changed 7 years ago by anonymous

also, i think that this patch:

https://dev.openwrt.org/browser/trunk/package/hostapd/patches/400-madwifi_key_fixes.patch?rev=23933

might be what broke it, based on my brief look it it, the code looks like it might be assuming that wep could only be static keyed

comment:2 Changed 7 years ago by anonymous

I can confirm that after deleting the lines from the patch that affect lines 441-445 this issue is resolved. I don't know what the purpose of these lines are though and if they can be fixed in a different way.

comment:3 Changed 7 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r24032

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.