Modify

Opened 7 years ago

Closed 7 years ago

Last modified 3 years ago

#8263 closed defect (fixed)

LuCi incomplete: collecting Data...

Reported by: anonymous Owned by: jow
Priority: normal Milestone:
Component: luci Version: Trunk
Keywords: LUCI TRUNK Cc:

Description

Hello,

after switching to Luci-Trunk i have on nearly all config-sides

"Collecting Data..." bot nothing is showed up. Maybe missing
dependencys to solve for themes, libs, extra needed tools ?

Or another Sample: Applying Changes... Waiting for Router..

The Save & Activate ist mostly not working. Changes are Saved, but things like Wireless-restart no longer works

Attachments (1)

LuCI Collecting Data.jpg (51.2 KB) - added by ledwards@… 7 years ago.
Screenshot of "Collecting data..." problem.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 7 years ago by anonymous

Are you using IE? I found if I use IE then it will always show collecting data, switch to chrome fix that.

comment:2 Changed 7 years ago by jow

  • Owner set to jow
  • Status changed from new to accepted

I believe http://luci.subsignal.org/trac/changeset/6475, http://luci.subsignal.org/trac/changeset/6476 and http://luci.subsignal.org/trac/changeset/6477 will also help. Plus make sure that "luci-theme-base" is installed, it had a broken dependency previously.

comment:3 Changed 7 years ago by jeyjay

correct, as of r24019 "Collecting Data..." disappeared. The new menu looks really pretty. Thank you jow.

comment:4 Changed 7 years ago by anonymous

I compiled last night the latest trunk/snapshot, and with the feeds-update
right now i get no new patches & fixes for luci ?!

Are you sure that it is -really- fixed TODAY ?

luci-theme-base WAS installed yesterday, that was not the case.

Please try out byourself using IE or Firefox. There are more Problems.
Stats are not read and "Save & Apply" nearly nowhere is working.

comment:5 Changed 7 years ago by jeyjay

no, for me it is working as advertised. I'm using firefox.

Before r24019 I used r23935 (where I had the "Collecting Data" problem).

Try to make a fresh checkout of the whole repository. Jow also switched to Luci trunk. If Luci 0.9 was used before, you can run into trouble.

comment:6 Changed 7 years ago by anonymous

tryed right now with checkout 24022 and still "Waiting" in IE 8.0
i´am using "german" Templates by the way.

Testing with Firefox it works. So IE8 is no longer working with Luci-Trunk!

After activating WLAN first time LED-Status is not updated/wireless not completly reloaded. And on Orion WLAN device is not a member of the LAN-bridge Group, and when manually by Luci, it is not added to the bridge.

After switching WAN from "default" to pppoe: Update stalled, like IE8 and never stopped.

The usualy "Apply Changes..." and nothing happend. Coldstart is needed.

IE8-Error:

Meldung: Syntax error
Zeile: 114
Zeichen: 1
Code: 0
URI: http://192.168.2.2/cgi-bin/luci/;stok=2ae1ee8ebf6ca4dc69d1cbb6faf339bc/admin/index/luci

comment:8 Changed 7 years ago by jow

I cannot reproduce the hang thing with IE7 anymore. On what device do you test? Mine is relatively fast so maybe I'm overseeing some timing related issues.

comment:9 Changed 7 years ago by ledwards@…

I'm having the "Collecting data..." problem on the Interfaces and Wifi pages. I'm running the latest trunk (r24063) w/ latest LuCI trunk on IXP4XX. See attached screen shot.

Before updating to the new LuCI, I executed a "make distclean" then a "svn up"... everything built fine. I will try creating a new build from scratch now, to make sure there were no issues with the transition from 0.9 to trunk.

Changed 7 years ago by ledwards@…

Screenshot of "Collecting data..." problem.

comment:10 follow-up: Changed 7 years ago by jow

Did you clear your browser cache as well?
If you access .../admin/network/iface_status/lan,wan (you need to edit the current url), do you get a response?

comment:11 in reply to: ↑ 10 Changed 7 years ago by ledwards@…

Replying to jow:

Did you clear your browser cache as well?
If you access .../admin/network/iface_status/lan,wan (you need to edit the current url), do you get a response?

Clearing the browser cache fixed it. Thanks! The new interface looks great.

comment:12 Changed 7 years ago by jow

Anyone else here seeing issues that are not yet resolved by the latest changes and a browser cache reset?

comment:13 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from accepted to closed

No complaints for seven weeks so I assume it is solved.

comment:14 Changed 6 years ago by grin

Still seen that and browser cache clear fixed it, feels like a FAQ to me. ;-)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.